Can't install sqlite

Hi, any ideas why I can't install sqlite on my pi-zero.This is the install log:

2020-05-22T12:26:14.219Z Install : node-red-node-sqlite 0.4.3

2020-05-22T12:26:57.020Z npm install --no-audit --no-update-notifier --save --save-prefix="~" --production node-red-node-sqlite@0.4.3
2020-05-22T12:28:07.979Z [out]
2020-05-22T12:28:07.979Z [out] > sqlite3@4.1.1 install /home/pi/.node-red/node_modules/sqlite3
2020-05-22T12:28:07.979Z [out] > node-pre-gyp install --fallback-to-build
2020-05-22T12:28:07.979Z [out]
2020-05-22T12:28:14.674Z [err] node-pre-gyp
2020-05-22T12:28:14.686Z [err]
2020-05-22T12:28:14.696Z [err] WARN Using request for node-pre-gyp https download
2020-05-22T12:28:16.186Z [err] node-pre-gyp WARN Tried to download(403): https://mapbox-node-binary.s3.amazonaws.com/sqlite3/v4.1.1/node-v64-linux-arm.tar.gz
2020-05-22T12:28:16.186Z [err] node-pre-gyp WARN Pre-built binaries not found for sqlite3@4.1.1 and node@10.16.0 (node-v64 ABI, glibc) (falling back to source compile with node-gyp)
2020-05-22T12:28:34.426Z [out] make: Entering directory '/home/pi/.node-red/node_modules/sqlite3/build'
2020-05-22T12:28:34.439Z [out] ACTION deps_sqlite3_gyp_action_before_build_target_unpack_sqlite_dep Release/obj/gen/sqlite-autoconf-3300100/sqlite3.c
2020-05-22T12:28:37.301Z [out] TOUCH Release/obj.target/deps/action_before_build.stamp
2020-05-22T12:28:37.363Z [out] CC(target) Release/obj.target/sqlite3/gen/sqlite-autoconf-3300100/sqlite3.o

What does it say at the end of the output? You haven't shown it all.

  1. go to /home/pi/.node-red/
  2. run npm rebuild sqlite3

Hi, thanks for your answers but somehow, sqlite is now installed. I installed sqlite3 on my pi zero, rebooted and tried again to install the sqlite node but no luck. I then replaced the sqlite node with a mysql node and continued developing my flow when I noticed that a second sqlite node I had on the same flow actually showed the sqlite node as being installed, very weird. Anyway, its now working...cheers

The log you posted did not say that it had failed. You may get lots of messages when you install it, but you have to look right at the end to see whether it actually failed or not. Probably it was fine the first time. You might have to restart node-red to see it, I don't know.