Installing node-red-node-sqlite gets 403 and then does a compile


#1

It looks like SQLITE is not part of raspbian and if you try to install node-red-node-sqlite a 403 occurs and that causes a compile of sqlite. (see attached log).

If you use sudo apt-get install sqlite sqllite3 they will install but the same 403 error occurs installing node-red-node-sqlite and the compile happens.

LOG:

pi@mqttpizw:~/.node-red $ npm install node-red-node-sqlite

> sqlite3@4.0.1 install /home/pi/.node-red/node_modules/sqlite3
> node-pre-gyp install --fallback-to-build

node-pre-gyp WARN Using needle for node-pre-gyp https download 
node-pre-gyp WARN Tried to download(403): https://mapbox-node-binary.s3.amazonaws.com/sqlite3/v4.0.1/node-v57-linux-arm.tar.gz 
node-pre-gyp WARN Pre-built binaries not found for sqlite3@4.0.1 and node@8.11.3 (node-v57 ABI, glibc) (falling back to source compile with node-gyp) 
make: Entering directory '/home/pi/.node-red/node_modules/sqlite3/build'
  ACTION deps_sqlite3_gyp_action_before_build_target_unpack_sqlite_dep Release/obj/gen/sqlite-autoconf-3240000/sqlite3.c
  TOUCH Release/obj.target/deps/action_before_build.stamp
  CC(target) Release/obj.target/sqlite3/gen/sqlite-autoconf-3240000/sqlite3.o

#2

After trying again and letting the compile complete, I DO have the sqlite node !!

But why, if I install sqlite and sqllite3 via apt-get, does it still get compiled?


#3

I believe it is the node that is compiling. What you installed is the support for sqlite in the OS.


#4

The 'compile' on a pi2 took about 10 minutes