Sqlite3 not installed or broken


I've been trying to do reindex on my db but nothing happens when I run it through the node-red.
So I tried to do it through shell, but seems there is no sqlite3 installed.

Which is weid because node-red-node-sqlite works OK:

Also, there is this issue in /node_modules:

Here are some querry listings:

pi@odin:~ $ sqlite3
-bash: sqlite3: command not found

pi@odin:~ $ npm list node-red-node-sqlite
└── node-red-node-sqlite@1.0.1
pi@odin:~ $ npm list sqlite3

└─┬ node-red-node-sqlite@1.0.1
  └── UNMET DEPENDENCY sqlite3@5.0.2

npm ERR! missing: sqlite3@5.0.2, required by node-red-node-sqlite@1.0.1

pi@odin:~ $ dpkg -l | grep sqlite3
iU  libaprutil1-dbd-sqlite3:armhf        1.6.1-4+deb10u1                         armhf        Apache Portable Runtime Utility Library - SQLite3 Driver
ii  libsqlite3-0:armhf   

pi@odin:~ $ apt show sqlite3
Package: sqlite3
Version: 3.27.2-3+deb10u2
Priority: optional
Section: database
Maintainer: Laszlo Boszormenyi (GCS) <gcs@debian.org>
Installed-Size: 2,278 kB
Depends: libc6 (>= 2.28), libreadline7 (>= 6.0), zlib1g (>= 1:1.2.0), libsqlite3-0 (= 3.27.2-3+deb10u2)
Suggests: sqlite3-doc
Homepage: https://www.sqlite.org/
Download-Size: 839 kB
APT-Sources: http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages
Description: Command line interface for SQLite 3
 SQLite is a C library that implements an SQL database engine.
 Programs that link with the SQLite library can have SQL database
 access without running a separate RDBMS process.

Anyone know how to fix it?

Debian 10 buster
Node-red 2.14
Node 14

Assuming that you have a conventional install of node-red then you must do that from within your .node-red folder. For some reason it seems you have been installing nodes into your home folder. Possibly by running npm install from there.

It is not weird, node-red-node-sqlite includes its own driver, the command line utility does not have to be installed. If you want to use it then install it using apt.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.