Chamberlain MyQ integration changed

Years ago I integrated to Chamberlain MyQ garage door starting with the work of @nothingmn

This worked until 5/31/2020.

Someone mentioned online that they found that to use the API the key "username" and "password" now needs to have first letter in upper case.

I modified my function node to the following:

/* old used lowercase
msg.payload = {
    "username" : flow.get("myq.payload.username"),
    "password" : flow.get("myq.payload.password")
msg.payload = {
    "Username" : flow.get("myq.payload.username"),
    "Password" : flow.get("myq.payload.password")

msg.headers = {
    ContentType : "application/json",
    Accept : "application/json",
    MyQApplicationId : "Vj8pQggXLhLy0WHahglCD4N1nAkkXQtGYpq2HrHD7H1nvmbT55KqtN6RSF4ILB/i",
    Culture : "en"

return msg;

And it works again.

It seems Chamberlain and their parent company are not very integration friendly. They don't offer an officially documented API so people have reverse engineered it, I believe by sniffing the communications of the MyQ mobile app.

If you want integration and don't already have a Chamberlain (same for LiftMaster) garage door I would suggest you look for a different automation solution that embraces open integration so you can more easily use platforms like Node-RED, Alexa, etc.

I'm new to GIST so hopefully this works. Here is my fork:


Thank you! I didn't have time over the weekend to look into this and found your post right after searching this morning. This solved the issue for me as well.

1 Like

good to hear!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.