Conflict nodes / uninstal nodes

I warmly welcome,
I tried to install nodes/libraries to nodered with command npm install ... and i saw this

So then i tried to install it with Manage palette but it dont work. This node has a red triangle with an exclamation mark.

I tried to install others node but i have information that this node have a conflickt with this first.

I tried to unninstal this using command npm uninstal but this node still exist.

How can i dalete it and fixed it ? My sensortag is connected with my inteledison and i can display sensors information in putty. But i cant do this in nodered. Please help me.

Yours faithfully

What hardware and OS are you running on and what instructions did you use for installing node-red?

Hi @Colin . I am using a mock-up with IntelEdison with Yocto Linux. I used "npm install --unsafe-perm node-red" to instal nodered.

Can you post the terminal output you get when you start node-red please. That will tell us a lot about your environment. When posting logs please copy/paste rather than screenshot, if possible. When pasting it in use the same techniques as for code and flows as described in How to share code or flow json

@Colin, Sorry for screen, but when i updated npm i installed version 1.3.5 of nodered i installed pm2 to enable an autostart of Node-RED and now i havent got any output in putty. I send a screen when i used nodered 0.9.1 and started it with command
root@fablab:~/node-red-0.9.1# node red.js

Yours faithfully

That is an ancient version of node red and an ancient version of nodejs. Many current versions of nodes will not work in that environment.

Also if putty does not work then something is messed up in your system, which you need to fix.

Yes its old i know thats why i use now nodered 1.3.5, npm 6.13.4 and node 8.17.0.
I just want how to uninstall/delete node-red-contribe-sensortag and other nodes with conflict?
notered has not option uninstall. When i used command npm uninstall node-red-contribe-sensortag its still exist in notered.

You need to do it from the node-red folder AND it should not have an e
npm uninstall node-red-contribe-sensortag << wont work due to spelling
npm uninstall node-red-contrib-sensortag << try that instead

Node v8 is EOL. V12 is now in maintenance. V14 would be preferable.

Also, it looks like you have installed / run as root - this is not desirable.

npm uninstall node-red-contrib-sensortag << dont work

when i used it the red triangle with an exclamation mark ( screenshot 5)dissaper but node-red-contrib-sensortag still exist in manage palette and the others nodes still have conflict.

You need to be in the correct directory before running npm uninstall

from your earlier screenshots you were not!

When you start up node-red what does show


i installed pm2 and nodered start automaticaly without sending something. But when i used:
pm2 info node-red
pm2 logs node-red
i saw this:

@Colin @Steve-Mcl I would like to thank you for your willingness to help and understanding.
I used:
root@edison:~# cd ~/.node-red
root@edison:~/.node-red# sudo npm install node-red-contrib-sensortag

and now i can use this node but the data is incomprehensible. Can i fixed it? Or is this how the node is built? Or again i do somethink wrong?

Why is that?

Have you tried expanding the msg object to see its content?

Do you know how to extract items from a msg & its properies?

There’s a great page in the docs that will explain how to use the debug panel to find the right path to any data item.

Pay particular attention to the part about the buttons that appear under your mouse pointer when you over hover a debug message property in the sidebar.


@Steve-Mcl You have right the data was there. Thank you so much.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.