Connection Problem Windows 11

I have a Intel NUC with Node-Red and Mosquitto Broker. Localhost:1880 works perfect.
There is no connection with TCIP from a Laptop in the same Network. I tried to open the port 1880 with In- and Outbound rules. No success. The port is not open. I setted up Node-Red on my Macbook pro no connection to the UI on the Intel NUC. From all devices access to the Mosquitto Broker on the NUC works.
From my Laptop i can acces the UI on my Macbook. Is Node-Red blocking the port?

To make sure I understand

  1. You have node red and mosquitto running on the NUC
  2. From a laptop you can connect to mosquitto on the NUC
  3. From the laptop and a Macbook, in a browser, you cannot access node-red on the NUC
  4. Running a browser on the NUC you can access node red using localhost.

What happens if, on the NUC you try to access node red using the IP of the NUC instead of localhost?
Is node-red running in docker or something similar?

I just checked it here on a just newly updated laptop to windows 11 and it works as expected. From my phone on the same network I can acces iplaptop:1880 without any other configuration

What works as expected? You can access the NUC?

I am not the topic starter :wink: . I just answered him also because I was curious because just updated to windows 11. I think there is something else wrong.

On the NUC via IP the connection is refused.
There is no docker running.

Can you take a snapshot of the screen so we can see what you see when the connection is redused?

Sorry cannot attach a photo

The message is:
x.x.x.x. refused to connect.
Search the web for x.x.x.x
Checking the connection
Checking the proxy and the firewall

You can paste an image here directly

Ok thanks.

I was hoping to see what you put in the URL bar too, but I assume it was ?

Does the laptop you are trying to connect from also have an IP address 192.168.18.n ?

It might be worth resetting networking on the PC - netsh int ip reset as an administrator and reboot.

yes the port is 1880 and the laptop is on the same network with 192.168.18.xx.
I try to reset the networking.

Are you running windows on the NUC?

Yes Windows 11 Pro

Good morning
Problem solved. I uninstalled node.js then reinstalled v18.12.1 with the Windows installer.
I have not selected the additional tools during setup.
Now i have access to the editor and UI with the IP address from the NUC

Just to note that if you did not install the tools then you may have problems installing nodes that need to be built when they are installed.

OK Thanks for the info.
When i need one of this tools then i try to install manually.

Or just reinstall using the Windows installer and select the option, that does not affect any existing code.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.