Dashboard homescreen shortcut always opens "Tab 0" on tablets

Hey guys!

I'm using 3 different tabs for the dashboard, which I added as shortcuts on the homescreen on different mobile devices (2 Android tablets, 2 iPads).

Until a few days ago I was using Node-Red v0.17.5 with dashboard v2.6.1 on a raspberry pi 3b+
I added a homescreen shortcut on device 1(Android) pointing to RPI:1880/ui/#/1 and another shortcut on device 2 (iPad) pointing to RPI:1880/ui/#/2. Worked like a charm until then.

Now I started using NR on a Windows machine, Node-Red v1.0.3 and dashboard v2.19.3. Added all my flows back in and everything works alright up to that point.
But when I try to put my homescreen shortcuts on the tablets back up, it won't let me do that. I simply can't set the shortcut to WM:1880/ui/#!/2 as it will always open WM:1880/ui/#!/0.
(Notice the exclamation mark, that has been added, I guess that's from the NR update...)

Also, I don't want to show the title bar and I don't want to allow the swiping between the tabs, as there are other people using these devices (and the dashboards) too.

As I said, I tried on two iPads (running iOS 13.3 (17C54)) and two Android tablets (one is on Android 6.0.1, one on 5.0.2). Worked on all the devices with the RPI and NR v0.17.5., but not anymore with the new setup.

FYI: I could just save the tabs as bookmarks within the different browsers and different machines or operating systems, that works out as it should on all of them. But I'd like to have them as homescreen shortcuts (so that they open like an app, fullscreen mode etc.), to make it as easy as possible to access the different dashboards for others and so that these people can only see one specific dashboard.

I hope you get what I'm trying to achieve. Please let me know if you need further information about my setup.

Best regards,