Dashboard menu won't disappear

Forgive me if this is no new - but I'm in a bind. I use Dashboard constantly for my home control here in Spain and in back the UK (via vpn) and I check every day. Works a treat. I have near-identical setups in both locations with multiple tabs.

BUT the UK setup had to be recreated from a new RPi4 installation + my NR flows this week after a year of no updates - a failed SSD prompted the change. Everything works but the left menu in Dashboard will not disappear makeing mobile access near imposssible.

I assume somewhere along the line in Spain I did an update of something to do with Dashboard and forgot about it. What is the most likely reason the left menu will not disappear? Anyone? I am on holiday and can only access by mobile phone - vpn to uk turned then straight into :1880/ui - the first tab comes up along with the menu which normally only appears when I press top left of screen.

Help. Mobile screen is WAY too crowded to use with that menu on constantly.

In the Dashboard panel under Site > Options, have you got Click to show Side Menu selected?

Thank you Colin but yes definitely click to show side menu IS selected. Just checked. More ideas?

If you change that setting in the one that works does it give you exactly the symptom you see in the one that doesn't?
Try changing the setting in the problem one. Does it make any difference?

Ok, so sitting in a bar in Spain I just VPN'd onto the working Spanish Node red, selected an alternative to "click to show menu" and sure enough the menu stayed on permanently. I went back in and selected "click to show menu" and that did Nothing. The menu in Spain is now permanently ON just like the one in the UK. Ideas?

I think that there is a issue here, see below;


'Always show side menu' does not initiate a deploy request to save the change.

node-RED v1.3.5
Dashboard v2.29.3

I noticed the same stuck desktop menu. But when I chose Always show icons only, Depoy (full), then Click to show side menu, Depoy (full)... it worked to clear it for me.

Gunner and Paul-Reed, you are both officially my heroes of the day. It's a bug, presumably in Dashboard.. and that trick of selecting the wrong option, full deploy, then the right option, full deploy, worked perfectly.

I had wondered why selecting an option didn't seem to trigger any deploy at all, but panicked on my phone. Both installations fixed from the comfort of my hotel. A big thank you


1 Like

Hi Colin

Looking like a dashboard issue. No deploy triggered. See other comments including workaround. Fixed.




Changing to the wrong setting, full deploy, then the right setting, full deploy sorted the problem. Both my installs went bad, both now fixed. Ta.

@dceejay should someone submit an issue for this or is it the sort of thing is fixed in less time than it takes to submit?

hmm can't see why that wouldn't get set if changed - but can give it a poke.

Oddly, I am not seeing the problem (node-red 1.3.5, dashboard 2.29.3). When I change the setting it does enable the deploy button. This is on Ubuntu with Firefox.

Just for clarity, in case my post was confusing, others are seeing the problem with those versions. @Paul-Reed @Gunner @scargill any ideas what the difference between our systems might be?

One of my setups has been upgraded regularly, the other not for a year, but both have latest dashboard....can't think of anything else.

Is there anything in the browser console?

There won't be anything in the console as it seems to be a lack of update for some reason, not bad data. (well there may be - but I'd be very surprised)

I couldn't think of anything else that might help.

if in doubt - switch it (the option) off and on again :slight_smile:

1 Like

Details of my setups... NR in each case on RPi4 2GB and I'm using a Xiaomi (Poco X3) to view the Dashboard though I saw the same non-hiding side menu on Windows 10 in Chrome (all up to date). Anyway thanks to the "deply full" workaround I'm happy. Once I'm back in my office in Spain at the weekend I'd be happy to change the settings again then change back looking to see if the deploy comes up or not, if this is of any help at all. Can't do anything before then as I've just realised my Windows 10 tablet has the worst keyboard in the world. You would not believe how many corrrections it has take it send this message out. Meanwhile, just confirming everything is working.

AHAH, I just tried - "always show side menu" - partial deploy...works. "Click to show side menu" - partial deploy... works... That's on the phone... why is it working now? I've not upgraded anything since Tuesday... I didnt imagine the problem...

1 Like