Dashboard settings on backend page are empty

Hello all,

i use Nodered 3.0.2 in a docker enviroment.
It works very well an the dashboard UI is also working fine.
But on the backend page the settings for the dashboard are empty. There is no entry visible.

Dose somebody of you know this kind of failure and know how to fix?


My first question is, would there be a reason you're running 3.0.2? Newer versions are available that may fix issues like this. Second, what version of Dashboard are you using? That may be an issue by itself. Keeping up to date helps, especially since it's so easy to do inside Node-Red itself. It may take a deinstall/reinstall to fix it.

Outside of that, have you tried the simple things like clearing your browser cache and what not? If your dashboard is loading properly, then it says that those nodes are at least working, which lends to maybe having old data in your cache. Trying the editor window from a different machine entirely may help point you in the right direction.

Finally, I've found there are still issues with Dashboard. My layout editor wouldn't load the layout for the longest time until I started trying to do things manually. Then it worked for a while, but now it's stuck on an old layout that doesn't match the current layout and won't refresh no matter what I try. But I can still change the layout manually so it keeps working. But I also have access to the page, which apparently has broken for you.

Try the simple things first. Dashboard has had a long time since its last update, and I think a lot of things are breaking because of it. Hopefully someday it will be picked up again and refreshed.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.