Dashboard layout editor ERROR


After the update, I can no longer resize my layout. I tried in 3 different browsers.

I have noticed that similar issue on occasion. Generally reopening browser cleared it... else a simple stop and restart of Node-Red got me going again.

Update of what? Node-Red or the Dashboard or both?

Dashboard(1 week ago). But I can't turn the system off and on, it hurts me. My system is an active program.

I deleted the cookies and tried again. Unfortunately it doesn't.

I have set up separate Node-RED instances for my Dashboard(s) and the "core", communicating via MQTT. Makes such circumstances a bit easier, plus, you can update them independently.

I use it the same way, but I have some counters, so restarting is a bit risky. Will rebooting fix the problem??

Since it's a UI issue, I don't think restarting Node-RED or even rebooting would do any good. I'd go with a reload (F5) of the Browser tab running the editor. If that doesn't fix it, it could be a bug or regression.

As for the counters there a multiple solutions, so they wouldn't be lost after a restart:

  • you could setup the file-based context store
  • use MQTT retained topics

After upgrading the dashboard you must clear the cache in the browser using the browser menus to do that. Then force a full page reload.

I deleted all cookies and tried from different browsers. It didn't happen again.

What kind of mistake? I don't have any nodes currently not running.

Mistake? I don't quite follow what you mean... :sweat_smile:

Deleting cookies is not the same as clearing the cache.

So is it all working now?

Yesterday it fixed itself without doing anything. Now I am facing the same error again.

I added 4-5 "texts". Again I got the same error.