Dashboard ui not working

#1

hi there !
I have just installed node red and I wanted to try to make it work.
I perfectly started it and I tried to build up something.
Now the problem is when I'm trying to display the result in the dashboard in the browser using this link
' localhost:1880/ui/ ' I got this message back: ' Welcome to the Node-RED Dashboard
Please add some UI nodes to your flow and redeploy '.

I don't really understand what's going wrong with it.
can someone help me please ?

0 Likes

#2

It might be because you havent used any of the dashboard node. Try creating an inject node and wiring it to a dashboard text node and then deploying the flows, close the ui page and try it again

0 Likes

#3

I did it, but nothing works out

0 Likes

#4

Did you make sure to force a full refresh the page in the browser (often Ctrl+F5 but may depend on OS and browser)

If still no joy then restart node red and, in a terminal run node-red-log. Post the results here. That should show useful information about your system.

0 Likes

#5

This issue came up for me when flows would not fully deploy.
I rebuilt a new machine, and started to rebuild node red flows one at a time.
But nothing in the dashboard works unless all flows have all their definitions. Missing nodes are shown dashed and will prevent deployment.

0 Likes

#6

I have seen this with Internet Explorer - I suspect you are using Internet Explorer?

In fact, I'm seeing it now with dashboard version 2.13.0 on Node Red 19.5 and node-red 20 Beta3 (Corporate Environment - still forcing us to use IE11).

I haven't had time to debug this but from the errors in console, i suspect some functions that IE11 doesn't support are the issue? maybe?

Two errors I see are ...

Though these may be red herrings. Pictures are worth a thousand words :slight_smile:

Chrome...
Chrome

IE11...
IE11

Now as much as I despise the POS that IE11 is, we must (for now) support it :frowning:

Can anyone help resolve this?

Cheers.

0 Likes

#7

Forgot to mention...

I'm fairly certain this happens when IE is in default mode

Try this...

  • Open F12 (Press F12)
  • Select the Document Emulation Mode drop down (top right hand side of "F12 Developer Tools")
    Pretty Sure by default IE11 is set for Document Mode 5 (AKA as pile of crap MS attempted Web Browser Lock-in mode)
    *Set this to mode 11 (or Edge if its available) - Dashboard will now work.

I suppose a new line of question would be - is there a way to have the Dashboard web instruct the document mode to IE?

Something like this...
https://msdn.microsoft.com/en-us/library/ff955275(v=vs.85).aspx

0 Likes

#8

Interesting... I guess we could always add

<meta http-equiv="X-UA-Compatible" content="IE=edge"> 

If you think it would help ? Though as it's just in the dist/index.html it should be easy enough for you to add locally to test for us :slight_smile:

0 Likes

#9

I open the dashboard on an older machine with IE11 - one I have never used for node-red.

The dashboard did not display.

I added ...

<meta http-equiv="X-UA-Compatible" content="IE=edge">

... to dist/index.html

Hard refreshed browser (CTRL+F5)

Tada - worked.

NOTE: I cant be 100% certain it wouldnt have worked without this as now I cant get it to fail.

I suppose its no harm in adding the meta tag.

0 Likes

#10

Thanks for letting me know... will do so.

(you may be able to set it to ..."IE=6" or something ancient to force it bad again... then forwards again to double check..)

0 Likes