Data in influxdb


i have no experience with Node-Red, please help, because I tried for hours without success.

I read my energy counter with Tasmota flashed NodeMCU and sent the values over MQTT to Mosquitto broker. With MQTT Explorer I can see receiving of the correct values.
The next step is to write the data in influxDB and after this visualization with Grafana.

My problem is that here is a error message:
What is wrong?

Is payload["Haus "].Power in Measurement wrong?

Welcome to the forum @HansPeter

In that case I recommend watching this playlist: Node-RED Essentials. The videos are done by the developers of node-red. They're nice & short and to the point. You will understand a whole lot more in about 1 hour. A small investment for a lot of gain.

Once you have done that, have a look at the help text for the influx node (that is visible in the right hand pane when you select the book icon at the top) and decide what format you need the data to be in order to send it to influx.

Is the time you want for each record actually the current time? If so then you don't need to provide it to influx, it will default to using the current time.

Thank you!

I worked with change Node to filter the data, now it works

It would be more efficient to save those as separate fields in one measurement, rather than use two separate measurements.

Thank you, I will try to do this. But I. don't know how to do this. I was happy that this works some how.
Is there some overview of the Nodes that are popular and works good?

Because I tried a WhatsApp Node. And my Node Red was brocken after press Deploy. Node Red restarts every 5 seconds without access to the Webpage. I needed to delete Node Red and to install new.

And a question more. If I install some Node Red Nodes I see that some Nodes in the package are not installed(are grey) and I can't use this Nodes. Why this is like this?

You should have seen an error when you tried to install them, and given the chance to view the log to see what is wrong.

In this situation I usually install using the command line where it can be easier to see what is wrong. Go into your .node-red folder (assuming this is a conventional install of node-red) and run
npm remove node-red-contrib-whatever
npm install node-red-contrib-whatever
Then you can post the full output here if it is not clear what the problem is. Start a new thread for those issues though.
In addition it is may be useful to look at the node's github page to see if there are a lot of open issues there, which is often a sign that it is no longer supported. The github page should be linked from the node red flows page for the node.

That is also a good thing to do any time you are using a new node, to give you an idea of how well supported it is.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.