Debug node produces output while muted

As subject, I have 1 debug node that produces output while it's muted, how is this possible ?

Happens to the best of us....

When it happens to me (on occasions), I toggle the debug node "on and off" and redeploy and all is well again :slight_smile:

Why it happens? That is above my pay grade.

are you sure it's not from another flow?

not from another flow: 100%

1 Like

Still, when looking into these things, you should select Current Flow as @ghayne mentioned, as your screen grabby shows All Nodes ...

Easy to reproduce, try this

  1. Disable the debug output, deploy your flow

  2. Now enable the debug output, you shall see messages coming into the debug window

  3. Refresh browser, debug node should now look disabled but messages are still coming in

Browser view simply out of sync

I can reproduce like this, but

  1. Now enable the debug output,

I always deploy when i see the lovely red button.
It must have been something in this direction.

Screen Shot 2020-03-07 at 5.22.55 PM

Change to current flow and try again ....

Screen Shot 2020-03-07 at 5.24.39 PM

Already known issue -

1 Like

@unixneo - look at the node id number and compare to the debug output i posted in the first post: same number, same debug node.

As I mentioned earlier....

Frankly, it's not a big deal and so I don't worry about it.....(bigger fish to fry.... )

Frankly, it's not a big deal and so I don't worry about it.....(bigger fish to fry.... )

It is a known bug as mentioned above.

I have from the start, and still think, it is ridiculous that the deploy button gets activated just because I toggle the debug node button, typical engineering not matching common sense

It is kind of weird, but I can imagine it is required in order to save the flow state by following the existing internal runtime functions, else, i suspect, it should follow a separate path internally, introduces other problems. Just a wild guess.

1 Like

@bakman2 that known issue is specifically related to Ctrl-Z not undoing the disabled state on the runtime side. Is that what you did?

If not, then this is a different issue.

@knolleary I can't reproduce my specific behaviour, I can replicate what @krambriw suggested. Will wait for reoccurance (and reproduction)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.