A suggestion to tweek the default name for the batch node:
- In "no of messages" mode include the number of messages batched.
So "batch 3" instead of just "batch"
- In "time interval" mode include the interval and unit
- In "concatenate sequences" mode, same default name as now
Similarly for the join node:
- In manual mode, include the number of message parts to wait for.
eg "join 4"
If "and every subsequent message" is ticked
- In automatic and reduce sequence mode, same default name as now.