Deploy failing. No response from server

I've hit the maximum number of responses allowed by the forum and was told to wait 18 hours so I created a new user account. I'll delete this one once I can use the other again...

Ok, deleted everything back to clean canvas including removing all config nodes. Here's what I find.
Created new flow with just inject hooked to debug. No problem.
Added one MQTT in node. Can deploy.
Configured MQTT node. Can deploy.
Added dashboard button node. Can deploy.
Configured dashboard button node. Now I can't deploy.

Tested several other variations and consistently I see everything works fine until I add a second node requiring configuration. The weird part is it was working just this morning with all four flows and a heap of configs. Now I don't know what to think. System limitation?

Now I'm able to reproduce it with nothing but three inject nodes connected to three debug nodes. Every once in a while it lets me deploy (just moving things around the page) but most of the time it fails as before.

Curious...

Are you using http or Https to connect to the node-red instance?

Are you certain unused config nodes have been deleted? (Check side bar).

When you say

... Are you adding a config node for each mqtt connection? There should be only one config node for one broker (you can have crap loads of MQTT in and MQTT out nodes but you should only have one config node)

Just http. And only one config for MQTT. Several for different dashboard configs (different tabs and groups). Not sure off the top of my head what the others were but I can set them back up and find out if you need them. I can confirm they're all deleted right now and I can reproduce the issue with just the three pairs of inject and debug nodes.

Is it possible that your issues are just network related? How reliable is your Pi's network connection? Are you both on the same WiFi network? It looks like your deployment problems are intermittent, which makes me think it's less likely to be code and more likely to be connectivity. Perhaps open a terminal and try pinging your pi and see if it's consistently answering?

Apart from dashboard and the built in nodes, try removing other nodes you added one at a time and retest deploy. Perhaps a contrib node is at fault?

Lastly, try re installing or installing v1beta3 (search this forum), perhaps you will have more luck?

Ps, is this a Pi? And if so, did you use the proper install script as stated in the documentation?

Thanks folks. Ping went through 99 out of 100 times. Should have been 100 and times varied from 3ms to 504ms. Most were under 10ms. I'm going to do some tinkering today.

It is a Pi. I used Pete Scargill's "The Script" to install. Wasn't aware of another install script but I'll be looking for it.

Also going to try alternate hardware today in case it's a system limitation of the Pi zero.

Thanks for all your time. I'll report back.

Node red will run fine on a pi zero provided you don't have a flow with hundreds of nodes or hundreds of messages per second flashing about. Also provided you are not running a graphical user interface or browser on the pi of course.

Thanks. No desktop so no gui or browser. Also set the memory split to only 16 for graphics. I just added a heatsink to the chip and it seems to be performing better. More testing ensues though.

You said earlier that you saw the problem with only a few inject and debug nodes. If that is correct then it is not to do with overloading the processor (unless you have something other than node red running that is consuming the processor). Run top in a terminal to see if the processor is heavily loaded.

Pete Scargill's "The script" installation script adds many third party nodes that aren't needed for this project. After manually uninstalling all of the unused nodes from the pallette the problem seems to have gone away. I'll report back if it reoccurs.

Thank you all for your time,
Terri

Generally it is recommended to use the script provided by the developers to install/upgrade node red on a pi
https://nodered.org/docs/getting-started/raspberrypi

I know this is old but I'd like to jump in here to add something quickly. I am having the same problem, and have narrowed it down to a specific flow. I can move nodes within that flow around and deploy, and copy and paste and deploy, but if I try to rename a function I then get no response from the server.

If I switch from Chrome to Internet Explorer, the problem goes away entirely. Does the fact that the browser makes a difference suggest a root cause not tried in this thread?

image

I got the same result. running in docker container

5 Jul 13:00:31 - [info] Node-RED version: v1.3.5
,5 Jul 13:00:31 - [info] Node.js  version: v10.24.1
,5 Jul 13:00:31 - [info] Linux 5.4.0-70-generic x64 LE

running in microsoft edge or google chrome not able to deploy at flow ,full or node level.