Flows not deploying

When deploying changes to a gitted project, the button gets greyed out and not deploys at all (waiting forever...) That started to happen after a very small change so I do not believed is related to code change inside project. Also, when I pull the git on another host, node-red deploys correctly.

The problem is that I have no log at all about the error. I Tried changing to "trace" on settings.js but even so, nothing unexpcted.

Actually, strangely node-red logs when I try to deploy with Chrome, and after a long 10/15 minutes waiting:

BadRequestError: request aborted     at IncomingMessage.onAborted (/usr/local/lib/node_modules/node-red/node_modules/raw-body/index.js:231:10)     at IncomingMessage.emit (events.js:198:13)     at abortIncoming (_http_server.js:448:9)     at socketOnClose (_http_server.js:441:3)     at Socket.emit (events.js:203:15)     at TCP._handle.close (net.js:606:12)

I have tried with different nodejs versions (10,14 and 17) and even with different node-red versions (1.2.5, 1.3.5 and 2.2.2), after complete purging the application from the system. The host is not using ssl (http) and using port 80. It's on production for over 3 yers now.

Appreciate any help to get over this.

Thanks in advance

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.