Deprecation warnings when installing

I decided to play with node-red. I have no experience with it or with node.js or with docker. I gathered that the best way to install it is to install the other components from the distro repositories, including npm, and then install node-red using npm. I run openSUSE Leap 15.0

When I ran the npm command from the node-red docs I got a bunch of warnings about deprecated modules/components/whatever (I don't know the correct terminology). Since I've no idea what I'm doing, I have no idea whether they matter, or how to fix them if they do. So I'm hoping that somebody who is
more familiar with this stuff than I am can tell me whether I need to worry. This is the npm output:

# npm install -g --unsafe-perm node-red
npm WARN deprecated mailparser@0.6.2: Mailparser versions older than v2.3.0 are deprecated
npm WARN deprecated nodemailer@1.11.0: All versions below 4.0.1 of Nodemailer are deprecated. See
npm WARN deprecated mimelib@0.3.1: This project is unmaintained
npm WARN deprecated mailcomposer@2.1.0: This project is unmaintained
npm WARN deprecated buildmail@2.0.0: This project is unmaintained
/usr/local/bin/node-red -> /usr/local/lib/node_modules/node-red/red.js
/usr/local/bin/node-red-pi -> /usr/local/lib/node_modules/node-red/bin/node-red-pi

> bcrypt@2.0.1 install /usr/local/lib/node_modules/node-red/node_modules/bcrypt
> node-pre-gyp install --fallback-to-build  

[bcrypt] Success: "/usr/local/lib/node_modules/node-red/node_modules/bcrypt/lib/binding/bcrypt_lib.node" is installed via remote
+ node-red@0.19.5
added 396 packages in 45.807s

Node-red does come up in my browser and apparently works.

@djh there are nothing for you to worry about - the email node's dependencies are currently pinned to these older versions whilst we support Node 4.x. The next Node-RED release drops support for Node 4 so we can move these dependencies up to the latest.

thanks @knolleary