Can we have a little chat about the look of the debug in complete object mode
1st look is great - says we've got an object called msg
Clicking on arrow we get
In my mind - I think it should say msg: object and not just object
My reasoning is, that when we click on the payload arrow we get
i.e it still says payload: object and not just object
The big one
When I look at this, due to the indenting, I read it as I have an object called msg, with inner objects called payload and completeData
And then within completeData, I have _msgid, myymd and mytimes
But I don't of course, I have 5 objects at the same level
Is it just me that gets confused?
What do other people think?
You aren't the only one to get confused
However, it is a fairly standard layout and I get the same cognitive dissonance in other applications as well
I guess I've always just assumed that it is how it is. Not that big a deal and I've never considered it enough of an issue to risk distraction from other developments.
Yes, I guess you are right, it would be more consistent. Probably easier for begginers to comprehend.
While re-loooking at item 2 - I'm wondering if it should be indented?
Slightly tricky to know - for me personally, the available width for showing information is important so I guess the question would be whether the clarity from indentation helps more than having space for information display?
This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.