EHOSTUNREACH after changing ips


I'm setting up 2 x pi's to read values from RS232 scales.
I've used the waveshare RS232 to ethernet converters
And followed the this link to get the ethernet and wifi working
Easy Raspberry Pi WiFi Bridge - Pi My Life Up
All this worked well and was saving the data into influx and I could access it from Grafana on another machine.
I have to have a static IP to maintain the links between the devices and that worked yesterday but today I could see the pi's on the router devices but could not access node red on the browser or via SSH.
I then changed it back to a dynamic IP and bound the IPs from the router.
After doing that I cant install nodes from the palette, previously installed nodes such as influx returns errors and I cant even update the pi in the cli.
I have rebooted several times and unbound the IPs from the router but still the same problem.

It is difficult to make suggestions based on such a vague description. Focus on one problem and work out what is going on. For example you you can't update from the cli. What sort of update is that? Show us what happens when you try. Copy/paste the result please, not a screen shot.

Have you restarted your router modem?

Can you check ping from PI to other local IP addresses?

Can you check ping from PI to

Can you check ping from PI to

What exactly does CLI show when you try to perform updates?

Hi Steve,
I can ping from other devices also i can access node-red via
It seems the LAN is working but no internet connection to the PI's
I'm currently replying to you from the network so the internet is good.
I have rebooted the router and the pi shows its connected to the network
This is what I get when running Sudo apt-get update

Cannot initiate the connection to (2a00:1098:0:80: 1000:75:0:3). - connect (101: Network is unreachable) Could not connect to raspb ( - connect (113: No route to host)
Err:2 stable InRelease
Cannot initiate the connection to (2a04:4e42:4::729). - connect (101: Network is unreachable) Could not connect to packages.grafana.c om:443 ( - connect (113: No route to host)
Err:3 buster InRelease
Cannot initiate the connection to (2600:9000:219c:b80 0:7:7790:e740:93a1). - connect (101: Network is unreachable) Cannot initiate the connection to (2600:9000:219c:c400:7:7790:e740:93a1).

pi@raspberrypi:~ $ ping
PING ( 56(84) bytes of data.
From icmp_seq=1 Destination Host Unreachable
From icmp_seq=2 Destination Host Unreachable
From icmp_seq=3 Destination Host Unreachable
From icmp_seq=4 Destination Host Unreachable
From icmp_seq=5 Destination Host Unreachable
--- ping statistics ---
9 packets transmitted, 0 received, +5 errors, 100% packet loss, time 300ms
pipe 4

2021-04-09T07:22:13.277Z Install : node-red-contrib-telegrambot 9.2.1

2021-04-09T04:35:43.326Z npm install --no-audit --no-update-notifier --no-fund --save --save-prefix=~ --production node-red-contrib-telegrambot@9.2.1
2021-04-09T04:35:48.336Z [err] npm
2021-04-09T04:35:48.337Z [err]
2021-04-09T04:35:48.337Z [err] ERR! code
2021-04-09T04:35:48.337Z [err] EHOSTUNREACH
2021-04-09T04:35:48.337Z [err] npm
2021-04-09T04:35:48.337Z [err]
2021-04-09T04:35:48.337Z [err] ERR!
2021-04-09T04:35:48.338Z [err] errno
2021-04-09T04:35:48.338Z [err] EHOSTUNREACH
2021-04-09T04:35:48.363Z [err] npm
2021-04-09T04:35:48.363Z [err] ERR! request to failed, reason: connect EHOSTUNREACH
2021-04-09T04:35:48.378Z [err]
2021-04-09T04:35:48.378Z [err] npm
2021-04-09T04:35:48.378Z [err] ERR!
2021-04-09T04:35:48.378Z [err] A complete log of this run can be found in:
2021-04-09T04:35:48.378Z [err] npm
2021-04-09T04:35:48.378Z [err] ERR!
2021-04-09T04:35:48.378Z [err] /home/pi/.npm/_logs/2021-04-09T04_35_48_366Z-debug.log
2021-04-09T04:35:48.392Z rc=1

I've seen something similar - was an issue related to ipv6. Try temporarily disabling IPv6

To disable IPv6 input 3 commands...

sudo sysctl -w net.ipv6.conf.all.disable_ipv6=1
sudo sysctl -w net.ipv6.conf.default.disable_ipv6=1
sudo sysctl -w net.ipv6.conf.lo.disable_ipv6=1

You can check if it worked using...

ip a

(uou should not see any IPv6 entries)


Sorry for the vague description on this thread but the problem wasn't to do with Node-red.
I found that i had to set the priorities for the adapters what happened was it was choosing the eth0 network over the wlan0 network so simply adding in metric 300 and metric 200 solved the issue
Thanks for the help
Raspberry pi priorities

Possibly a better way to solve that would be to setup static routes so there is no ambuity. Tell it to use one router one range of addresses and the other for the rest.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.