"Error: Cannot find module 'node-red-dashboard"

Hello im trying to upload an image, and it tells me this "Error: Cannot find module 'node-red-dashboard'"
i have created a Category and upload the image that i want, can somebody help me out

Your post leaves a lot unexplained

  • where are you trying to upload an image from/to
  • what do you mean you created a category?
  • have you installed 'node-red-dashboard'?

*Yes i have already a Dashboard

What node are you using to do the upload? node-red-contrib-?????

Can you provide your flow (read this first)

I have the same issue with a video node that is not shown.
I think the contrib is node-red-contrib-ui-media. Acts as a media player used to show pictures, video an audio. https://flows.nodered.org/node/node-red-contrib-ui-media (by gfcittolin on github).

The node load the video, and even you can preview it, but nothing is shown on dashboard. It seems that physical space is preserved but video does not appear.

The same on a Mac or Windows runs ok.
Tested with:
node-red 1.1.2
node-red-contrib-ui-media v1.2.0
Android 8.1.0

have you tried it with any other browser?

I solved it. Not sure which of the things I did:

First one:
Change credential option to false in settings.js as I read something about it.
Second one:
-Stop node-red
-Start node-red.
-Restart device

Hope this helps

I just have the same issue but with node-red-node-ui-table, i get the following console error when deploying:

Error: Cannot find module 'node-red-dashboard'
    at Object.requireModule [as require] (/usr/lib/node_modules/node-red/node_modules/@node-red/registry/lib/util.js:48:19)
    at new TableNode (/home/nemanja/.node-red/node_modules/node-red-node-ui-table/node.js:77:30)
    at Object.createNode (/usr/lib/node_modules/node-red/node_modules/@node-red/runtime/lib/nodes/flows/util.js:493:31)
    at Flow.start (/usr/lib/node_modules/node-red/node_modules/@node-red/runtime/lib/nodes/flows/Flow.js:193:48)
    at start (/usr/lib/node_modules/node-red/node_modules/@node-red/runtime/lib/nodes/flows/index.js:345:33)
    at /usr/lib/node_modules/node-red/node_modules/@node-red/runtime/lib/nodes/flows/index.js:212:21
    at processTicksAndRejections (internal/process/task_queues.js:93:5) {

And it seems like a quick node-red restart fixed the job :innocent:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.