Error: Module not allowed - UI Media


Newbie to Node-Red.
After installation the UI Module for dashboard i get the following error in CMD

[error] [ui_media:b29d1cdb02d2be5f] Error: Module not allowed

Tried both installaing by Palette and npm
Any sugestions ?

Hi @soerenbull - Welcome to the forums.

You might want to check your settings.js file - seems some modules have been prevented from being allowed to run

Thank you for quick reply.
Have an idea where to look ?

Welcome to the forum @soerenbull

I presume that error appears when you start node-red. Can you post the full output when you do that please, including the command line. Copy/paste not screenshot please. Use the </> button at the top of the forum entry window when pasting it in.

Thank you Colin.
you mean this ?

Microsoft Windows [Version 10.0.19045.2728]
(c) Microsoft Corporation. Alle rettigheder forbeholdes.

30 Mar 16:37:52 - [info]

Welcome to Node-RED

30 Mar 16:37:52 - [info] Node-RED version: v3.0.2
30 Mar 16:37:52 - [info] Node.js  version: v19.8.1
30 Mar 16:37:52 - [info] Windows_NT 10.0.19045 x64 LE
30 Mar 16:37:54 - [info] Loading palette nodes
30 Mar 16:37:56 - [info] Dashboard version 1.0.2 started at /ui
30 Mar 16:37:56 - [info] Settings file  : C:\Users\post\.node-red\settings.js
30 Mar 16:37:56 - [info] Context store  : 'default' [module=memory]
30 Mar 16:37:56 - [info] User directory : \Users\post\.node-red
30 Mar 16:37:56 - [warn] Projects disabled : editorTheme.projects.enabled=false
30 Mar 16:37:56 - [info] Flows file     : \Users\post\.node-red\flows.json
30 Mar 16:37:56 - [info] Server now running at
30 Mar 16:37:56 - [warn]

Your flow credentials file is encrypted using a system-generated key.

If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.

You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.

30 Mar 16:37:56 - [info] Starting flows
30 Mar 16:37:56 - [warn] [s7 endpoint:038fb96ac4ed4e5a] No variables configured, skipping cyclic reading
30 Mar 16:37:56 - [info] Node users started /users
30 Mar 16:37:56 - [error] [ui_media:b29d1cdb02d2be5f] Error: Module not allowed
30 Mar 16:37:56 - [info] Started flows

Check that file.

I think there is a section of externalModules, check here for any clue that may stop the module from running.

Maybe some of this `?

    externalModules: {
        // autoInstall: false,   /** Whether the runtime will attempt to automatically install missing modules */
        // autoInstallRetry: 30, /** Interval, in seconds, between reinstall attempts */
        // palette: {              /** Configuration for the Palette Manager */
        //     allowInstall: true, /** Enable the Palette Manager in the editor */
        //     allowUpdate: true,  /** Allow modules to be updated in the Palette Manager */
        //     allowUpload: true,  /** Allow module tgz files to be uploaded and installed */
        //     allowList: ['*'],
        //     denyList: [],
        //     allowUpdateList: ['*'],
        //     denyUpdateList: []
        // },
        // modules: {              /** Configuration for node-specified modules */
        //     allowInstall: true,
        //     allowList: [],
        //     denyList: []
        // }

That is not a supported version of nodejs, you should stick to an LTS version, 16 or 18. I don't use Windows so I don't know how to do that. The node red getting started docs for Windows should tell you how you should install it.

How on earth did you install that ancient version? The current version of node-red-dashboard is 3.4.0.

That is all commented out, so nothing wrong there.
Downgrade nodejs and install the latest version of the dashboard and I suspect you will be ok.

Upgraded dashboard. Everything works now.

Thank you!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.