ui_LED problem not showing on dashboard

#1

I have installed the ui_LED on one machine and it works. I send it either a true and the LED goes GREEN.

Sending a ~true and it turns RED.

This is on NR 0.19.4

I installed the node on another machine running NR 0.19.5.

I can't see the LED on the dashboard.

I'll try other things, but I'm stuck on what to do.

#2

what is the version of the dashboard?

#3

2.9.8

I've been trying for 20+ minutes to update it.
From the web page it just doesn't work.

Trying from the CLI. Same.

From the CLI in the .node-red directory:
npm install node-red-dashboard

NO LUCK! :frowning:

This is what I see:

pi@TimePi:~/.node-red $ npm install node-red-dashboard
npm WARN node-red-project@0.0.1 No repository field.
npm WARN node-red-project@0.0.1 No license field.

+ node-red-dashboard@2.9.8
added 1 package, removed 1 package, updated 8 packages and audited 874 packages in 848.829s
found 6 low severity vulnerabilities
  run `npm audit fix` to fix them, or `npm audit` for details

Back to "that old problem", I fear.

This is also a bit of other info which may be helpful.

pi@TimePi:~/.node-red $ tail /home/pi/.npm/_logs/2019-02-01T07_14_22_566Z-debug.log 
5 verbose stack     at <anonymous>
6 verbose cwd /home/pi/.node-red
7 verbose Linux 4.14.79+
8 verbose argv "/usr/bin/node" "/usr/bin/npm" "audit" "fix"
9 verbose node v8.12.0
10 verbose npm  v6.4.1
11 error code ELOCKVERIFY
12 error Errors were found in your package-lock.json, run  npm install  to fix them.
12 error     Missing: node-red-contrib-queue-gate@^1.1.0
13 verbose exit [ 1, true ]
pi@TimePi:~/.node-red $ 
#4

which bit of this suggests it failed to you?

#5

Well, for the last hour I can not update the dashboard from 2.9.8 to the latest.
The other machines have 2.13.x

The gui doesn't appear on the dashboard.

So I am trying to update from the CLI.

Still not working.

It completes, gives the reply as shown.

pi@TimePi:~/.node-red $ npm install node-red-dashboard
npm WARN node-red-project@0.0.1 No repository field.
npm WARN node-red-project@0.0.1 No license field.

+ node-red-dashboard@2.9.8
added 1 package, removed 1 package, updated 8 packages and audited 874 packages in 848.829s
found 6 low severity vulnerabilities
  run `npm audit fix` to fix them, or `npm audit` for details

I reboot (not really happy doing it, but....)

Same version of the dashboard. 2.9.8

So, what do I do now to get it updated?

I am trying, but it is just confusing me.

The program gives me messages saying things are not up to date.
I am told to not worry about them.

So.....

Stuck.
:confounded:

#6

Some how it has now updated.

The dashboard is now up to date and the LED is now showing.

#7

Spoke too soon.

The LED appears, but sending true or false the LED doesn't change colour.

Code:

[{"id":"f1ee051d.a087c8","type":"inject","z":"c636aa5a.cc34","name":"","topic":"","payload":"false","payloadType":"bool","repeat":"","crontab":"","once":false,"onceDelay":0.1,"x":3490,"y":1860,"wires":[["511451c8.b6077"]]},{"id":"6aa4b5df.f7408c","type":"inject","z":"c636aa5a.cc34","name":"","topic":"","payload":"true","payloadType":"bool","repeat":"","crontab":"","once":false,"onceDelay":0.1,"x":3490,"y":1900,"wires":[["511451c8.b6077"]]},{"id":"511451c8.b6077","type":"ui_led","z":"c636aa5a.cc34","group":"bb53947.22a3b68","order":1,"label":"Main","name":"Main","x":3630,"y":1940,"wires":[]},{"id":"bb53947.22a3b68","type":"ui_group","z":"","name":"Telemetry","tab":"e57b580a.89d2d8","order":3,"disp":true,"width":"6","collapse":false},{"id":"e57b580a.89d2d8","type":"ui_tab","z":"","name":"JUNK1","icon":"dashboard","order":26}]

Screen shots:

1 Like