Error: EFATAL: Unsupported Buffer file-type for Video Version 3.0

Good day

I just updated Node-RED container, I was able to send videos got by my camera in Home Assistant in the previous build 2.x, now with this update, whenever I try to send videos with my telegram bot it says that

Caught exception in sender node:
Error: EFATAL: Unsupported Buffer file-type
when processing message:
{"_msgid":“d092c532152ec973”,“payload”:{“type”:“video”,“chatId”:“XXXX”,“content”:{“type”:“Buffer”,“data”:[0,0,0,3…

I have tried many solutions:

  1. I tried to install

npm install bufferutil utf-8-validate

  1. I tried to update npm and node, these are my versions:

The node itself is doing a get, it is a mp4 video (and as I said, it used to work on 2.x)

image

Has anyone faced it? How could I solve this?

This is cross posted at home assistant forums as well

Coming from HA forum I assume you have read this entire thread.

Hi Steve, thanks for your reply

I did, the only problem is with video, the bot is working for other media, pictures work fine for example. I found a solution that uses HA to communicate to the telegram bot and then send the video using HA service instead of the native node red, but I think that's not the optimal way, the TB is configured only in node red and was working fine before, worst case scenario would be to revert to 2.x, I just did it for this year version whereas the problem on that thread seems to be for 2019. The TB is configured with the node-red-contrib-telegrambot.

I found this one as well so I attach the

msg.payload : buffer [237212] buffer[237212] [raw]

isom/iso6/iso2/avc1/mp4