Error from unknown node

this error isnt relate to any of my flows, and it repeat every 5 second , how I can fix it ?

Click on the node ID in the top right corner of each debug message
That will take you to the node that is logging the error.

From there it will depend on what node it is. The error message sounds like a database node...

I tried but it is not click able unfortunately , and I checked all of my dB nodes too ,I didn't find any thing

You seem to have a lot of browser tabs running Node-red.
Are any of the other tabs Node-red on the same server (
The tab you posted a screenshot of has undeployed changes.

Maybe try deploying and closing all the other Node-red tabs will make it easier to track down the problem.

Have you tried searching (ctrl-f) for that id? It must exist somewhere in your flows for it to be logging like that.


And the node id is definitely not clickable? That is odd. What version of Node-RED is this?

Do you have any subflows?

no a dont have any
and version is :v14.17.6

That looks like a Home Assistant install where Node-RED is packaged specifically for Home Assistant (by HA). You might be better to ask on the HA Forums

No. Why would HA forum help understand a Node-RED specific thing? There's nothing here related to HA.

@sahar but as @mudwalker says, that isn't a Node-RED version number. You can check the Node-RED version at the bottom of the main menu in the editor.

o sorry ,this is v2.0.6

It looks like you have undeployed changes. Have you deleted this node or something to do with SQL and forgot to deploy?

Even if you have deployed and removed a SQL config node, it may somehow be stuck in memory - have you restarted node red?

I removed all nodes related to SQL ,and restarted node red , it works finally , thank you ...

Ooops, sorry not sure what happened, probably finger/brain problem at my end (as usual)! Glad it is sorted.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.