TypeError: runtime.flows.loadFlows is not a function

Imported a via palette manager a node
json-db-node-red.
Did not worked as I hoped it would.
After some trials witch did not worked for me I wanted to delete the node.
But the deploy button stays red and there is no response when I push it.
When I do a restart flows I get
"Deploy failed TypeError: runtime.flows.loadFlows is not a function"
I have stop/started node-red, no avail.
What can I do to get node-red running again.

Edit : after flushed the browser cache, Node-red started again with the deploy button grey, pfff

Edit 2 The problem exist, after I remove the node from the tab, the deploy gives the same old error above.

Hi @yogy - this was fixed in the 1.2.2 release.

I see, thanks, updating, I am on 1.2.1.

After updating I now have the following problem.
When I change something on the tab where I used the node that I had imported (json-db-node-red) The deploy button stays red, the warning has disappeared.
When I delete the tab , the deploy button stays red, and when I reload the page the tab is back.
When I reload the node-red page in the browser, I can make changes on other tabs without problems, deploys works

Have you tried clearing the browser cache? It may not help, but worth doing just to rule it out.

Clearing the cache did not work, nor using a different browser
I have cleaned the tab so that only the new node "datain" from the json-db-node-red is present.
All other nodes removed, nothing else then the "datain" node.
When I change something with that node, just moving it on the screen, the deploy button becomes red, but does not react and stays red.
The only thing I can do at that moment is reload the page, that undo the change and the deployment button is grey again.
On other tabs all works fine, changes and deploys work.

So now I have one tab with one node that is not removable, changeable or anything.

And of course json-db-node-red is not removable in the palette manager because it is “used”

If you open a terminal and go to your .node-red folder and run
npm remove json-db-node-red
then restart node-red then it should start node red but not start the flows because of the missing node. In the browser then refresh the page and perhaps you will be able to delete the node.

@Colin

Thanks, half way there
After following your instruction it was possible to delete the node and the TAB
The node is now not present anymore in the palette manager.
But now I have a warning triangle witch says:

Flows stopped due to missing node types.

  • json-db-collection

And every time I do a deploy I get the same warning.

I expect that is a Config node.
In the hamburger menu go to Configuration nodes and click Unused. Then I expect you will see it there. Select it and click Delete.

Not present, I had that one removed already.
Should I try to install and then remove again the * json-db-collection ?

Do you mean there was a config node json-db-collection and you have deleted it?

Use the search feature in the editor to search for json-db-collection and see what it shows.

Yes I deleted the config node, is not present anymore.
What is more troubling now is that my home automation is down, of course because the nodes have stopped.

Note to myself, use a different node-red instance to experiment :cold_sweat:

You didn't say what happens when you search for it. First though try restarting node-red and refresh the browser page.

[Edit] If all else fails and you need to get the system up and running then restore your flows file from your backup.
If you can't do that for some reason then make a copy of the flows file in case it gets messed up then edit it with a text editor (not a word processor), search for the node and delete the reference (or references) to it. The file is json and you need to make sure you delete from the { at the start of the entry for it up to the matching } at the end and also the comma after it. Then restart node-red. If you get errors on starting then you have messed up the edit. Copy the backup back and try again. Be careful not to mess up your copy!

When I search for it I see
Screenshot_20201102_125922

I have restarted & refreshed, no avail.
My lights are out!

It isn't node json-db it is json-db-collection

@Colin
pff, you right.
I omitted the - in "node json-db"
with json-db-collection it did not find anything.

I had a json-db node in one of my other tabs.
Unstructured trying out from me when i started the node-db exercise

Oke, with your help lesson learned.
Do not try new nodes in your production system.
Think about a fallback if your pi or .. stops working.

Thanks again

Remember that a Pi SD card may go AWOL without warning, particularly if you have a power cut. It is a good idea to keep control of your flows using the Projects feature or something like git so that you can always revert to the previous working version. Also for the card itself a card image backup is a good idea.

Yes, good advice, I'm running the pi with a cheap ssd
But I now taking an old rpi3 for working spare if things go awol