Issue: flows stopped due to missing node types

Hi, I'm using the NodeRED with IBM cloud. I import a json. file and the error "Flows stopped due to missing node types". I have tried to install the required nodes by checking the palette: node-red-dashboard, but it shows conflict so I cannot install the nodes. Please help

It looks like you have cn-cashboard-nodes installed which is probably the reason for the conflict. You can have one or the other but not both installed.

Hi, thanks for replying.
It shows the source of conflict is node-red-contrib-ui, so I actually did check the module installed but I cannot do anything on this module.

yes you have to remove that node-red-contrib-ui first - then reload node-red-dashboard

Hi, I can't remove that due to some "in use" nodes. Is there any other way to remove that ?

stop Node-RED
at command line go into your user directory - usually ~/.node-red (but the startup log in the console should tell you)
then - npm uninstall node-red-contrib-ui
then - npm install node-red-dashboard
restart Node-RED

1 Like

@dceejay - he is running NR on the IBM Cloud - are the instructions the same?

ah - sorry didn't spot that... no :slight_smile:
Really need to turn on the dev pipeline - then go into the file tree and edit the package.json to remove that dashboard and add the correct one - then commit/deploy/re-stage the app to rebuild it.

1 Like

Thanks ! It works !

Hello good morning
I have this same problem. I cant even sim to fine the node which are missing but i get this error. And it then shows me flows stoped. And wen i go to ui node i am told to place dashboard nodes, wen i have a lot of them. Please help me, i am doing a project an running out of time.

what nodes does it say are missing ?
do you have them installed ?
Can you (re)install them ?

It says

Those are the missing nodes. I did a flow containing this nodes but i deleted de flow but still the nodes are still disturbing. I tried installing them back be there is no success

well if you don't need them - uninstall them.

I hv deleted the flow that had them but i still get the error

Thank u all i go it
The problem was because the nodes that were disturbing were in a sub flow and i was checking in the flows so i have to delete them on by one

sorry i'm new here...
how to go into the file tree and edit the package.json?

Why would you do that?

If you have the warning about missing nodes you have 2 options...

  1. install the missing nodes
  2. Remove the nodes from your flow that appear as dotted outlines & deploy

Note, also check for unknown nodes in the configuration nodes in the right-hand side bar.


What did you do prior to this happening?


I also received this error and had something similar to Chenko. After adding the nodes which are not installed, I deleted the problem nodes, but still received the error.

I am not sure if it is a bug, but if you go under "config" (next to debug messages) you can see that information about the node still gets retained after deleting (login/configuration information) the problem node.

Once you delete this config data the flows deploy again and work as intended.

Kr, Arjun

1 Like

NODE-RED : Flows Stopped Due To Missing Node Types. Check Logs For Details

Rédigé par Stéphan - samedi, 30 décembre 20172 commentaires

Hii, I had the same problem on node-red: Flows stopped due to missing node types. Check logs for details.
At the beginning, I searched a lot of information and I found this forum, but the solutions didn't work.
Now I think that I found the solution:

  • First of all, on your node-red web, click on " Configuration nodes / On all flows "
  • There enter one by one and delete everything (in my configuration I find four sections).
  • To save the changes, click Deploy

Also, to guarantee the problem is solved, I delete all the palettes that could be removed:

  • Click on " Manage palette "
  • Delete all that could be deleted.

Rédigé par Stéphan

I don't think this is a recommended solution to the problem.

The first step should always be to check the node-RED log, and see if the problem is described.
If users don't understand the log, they can always copy & paste it in the forum to get further help.