Error in node tfcocossd

Hello everyone
I have problem using node tfcocossd on my image detection flow. I tried my flow on my local server and raspberry pi server.
when I tried in local server, it worked. But when i try in raspberry pi, i got an error.
Anyone has solution? here i drop screenshot of error message.

  • Node red version : v2.2.2
  • Node.Js Version : V16.16.0

Thanks in Advance!


What OS are you running on the pi?
Are you running a 64 bit version?

There is a GitHub issue about this but it was closed as solved

I would suggest you go to the GitHub issues area for the node you are using (I can’t tell you which since you didn’t provide the name of the node…I.e. node-red-contrib-?????) and open an issue

I use Debian OS 32 bit
when i search issue about node-red-contrib-tfjs-coco-ssd, i didn't find the solution because in my case, I installed the node directly from node red.
Anyway Thank you for suggest the link

On a Pi - you will also need to run this command after the main install.

cd ~/.node-red
npm rebuild @tensorflow/tfjs-node --build-from-source

then restart Node-RED

1 Like

Thank you very much! it solved because i install the previous version of tfjscocossd node and run npm rebuild @tensorflow/tfjs-node --build-from-source

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.