Error: node not deployed - Cant delete the Error

I have a very simple flow.


I have copied a flow somewhere with "mraa-gpio-dout" in it, I did not have the node installed.

I deployed the flow without installing the node.

Subsequently I have installed the node but

Keeps telling me -
Flows stopped due to missing node types.

I have deleted the flow as well and tried to start and send messages, but it keeps telling me "Flows stopped due to missing node types. mraa-gpio-dout" and "Error: node not deployed"

1 Like

Try (on commandline):

node-red --safe

It will start node-red in safe mode, remove the nodes that give the problems, deploy.

If that does not help tell us how you have installed node-red and what hardware and operating system it is running.
Also post here the startup log that you see when starting node-red in a terminal. It should include the Welcome to node-red message.


Start up in safe mode log.

""pi@raspberrypi:~ $ node-red-stop

Stop Node-RED

Use node-red-start to start Node-RED again

pi@raspberrypi:~ $ node-red --safe
17 Jan 21:49:02 - [info]

Welcome to Node-RED

17 Jan 21:49:02 - [info] Node-RED version: v0.20.7
17 Jan 21:49:02 - [info] Node.js version: v8.11.1
17 Jan 21:49:02 - [info] Linux 4.19.66-v7+ arm LE
17 Jan 21:49:05 - [info] Loading palette nodes
Initializing chat-platform lib, you should see this only once
Running at: /home/pi/.node-red/node_modules/chat-platform Version: 1.0.9

node-telegram-bot-api deprecated Automatic enabling of cancellation of promises is deprecated.
In the future, you will have to enable it yourself.
See module.js:652:30
17 Jan 21:49:18 - [info] RedBot version: 0.18.3 (node-red-contrib-chatbot)
17 Jan 21:49:33 - [info] Dashboard version 2.15.4 started at /ui
17 Jan 21:49:35 - [warn] ------------------------------------------------------
17 Jan 21:49:35 - [warn] [node-red-node-intel-gpio/mraa-gpio-ain] Error: Cannot find module 'mraa' (line:3)
17 Jan 21:49:35 - [warn] [node-red-node-intel-gpio/mraa-gpio-din] Error: Cannot find module 'mraa' (line:3)
17 Jan 21:49:35 - [warn] [node-red-node-intel-gpio/mraa-gpio-dout] Error: Cannot find module 'mraa' (line:3)
17 Jan 21:49:35 - [warn] [node-red-node-intel-gpio/mraa-gpio-pwm] Error: Cannot find module 'mraa' (line:3)
17 Jan 21:49:35 - [warn] ------------------------------------------------------
17 Jan 21:49:35 - [info] Settings file : /home/pi/.node-red/settings.js
17 Jan 21:49:35 - [info] Context store : 'default' [module=memory]
17 Jan 21:49:35 - [info] User directory : /home/pi/.node-red
17 Jan 21:49:35 - [warn] Projects disabled : set editorTheme.projects.enabled=true to enable
17 Jan 21:49:35 - [info] Flows file : /home/pi/.node-red/flows_raspberrypi.json
17 Jan 21:49:35 - [info] Server now running at
17 Jan 21:49:35 - [warn]

Your flow credentials file is encrypted using a system-generated key.

If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.

You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.

17 Jan 21:49:35 - [info] Waiting for missing types to be registered:
17 Jan 21:49:35 - [info] - mraa-gpio-dout
^C17 Jan 21:53:55 - [info] Stopping flows
17 Jan 21:53:55 - [info] Stopped flows
pi@raspberrypi:~ $""

When I started it in safe mode it showed the unconfirmed nodes

I remove them - Deployed the flow
node-red-stop - Stoped the flow
node-red-start - Started node red

Re-arranged my flow again

And Now we are working 100%


1 Like


This mraa-gpio-dout are back and causing trouble for me.

I have once again tried to node-red-stop and then node-red --safe then remove mraa-gpio-dout.

Any other advice?


To find more nodes and example flows - go to

Starting as a systemd service.
20 Jan 22:53:53 - [info] - node-red-node-pi-gpio:rpi-keyboard
20 Jan 23:02:22 - [info] Stopping flows
20 Jan 23:02:22 - [info] Stopped flows
20 Jan 23:02:22 - [info] Waiting for missing types to be registered:
20 Jan 23:02:22 - [info] - mraa-gpio-dout

node-red --safe 

Then remove the nodes from your flows first.

I don't have the nodes "mraa-gpio-dout" in any flow

If you have not already done so, use the Search feature in node red to search for mraa.
If that doesn't find anything then in a terminal in the .node-red folder run
npm remove node-red-node-intel-gpio
And post the result here. Then restart node red and see what happens.

1 Like

Thank you Colin, your help is appropriated

Is it fixed then? If so what did it?

I could not find it in the flow or node causing the trouble, also there were flow shown under "config" image
and not at the top of the flows image (I have subsequently delete them, you will only see the two now, I should have take screen shots to demonstrate prior of me deleting them)

I used Ctrl+f and searched for the nodes and flows that were not shown on the mail pallet and deleted them.

As you can see only the two flow I use now there and the rest deleted.

Think node-red got it self in a bit of a knot, as I have copied and pasted a lot of flow, experimenting on how thing work.