Error rc=226, can't install any nodes. EROFS?

Hi, I'm getting this error when trying to install any nodes:

2023-03-06T23:19:39.233Z Install : node-red-contrib-timerswitch 1.4.0

2023-03-06T23:19:29.415Z npm install --no-audit --no-update-notifier --no-fund --save --save-prefix="~" --production node-red-contrib-timerswitch@1.4.0
2023-03-06T23:19:44.776Z [err] npm
2023-03-06T23:19:44.779Z [err]  
2023-03-06T23:19:44.781Z [err] ERR!
2023-03-06T23:19:44.782Z [err]  
2023-03-06T23:19:44.784Z [err] code
2023-03-06T23:19:44.786Z [err]  EROFS
2023-03-06T23:19:44.791Z [err] npm
2023-03-06T23:19:44.793Z [err]  
2023-03-06T23:19:44.795Z [err] ERR!
2023-03-06T23:19:44.797Z [err]  
2023-03-06T23:19:44.798Z [err] syscall
2023-03-06T23:19:44.800Z [err]  open
2023-03-06T23:19:44.802Z [err] npm
2023-03-06T23:19:44.804Z [err]  
2023-03-06T23:19:44.808Z [err] ERR!
2023-03-06T23:19:44.812Z [err]  path /.npm/_cacache/tmp/51acc654
2023-03-06T23:19:44.819Z [err] npm ERR! 
2023-03-06T23:19:44.834Z [err] errno -30
2023-03-06T23:19:44.863Z [err] npm
2023-03-06T23:19:44.865Z [err]  
2023-03-06T23:19:44.868Z [err] ERR!
2023-03-06T23:19:44.870Z [err]  
2023-03-06T23:19:44.872Z [err] rofs
2023-03-06T23:19:44.873Z [err]  EROFS: read-only file system, open '/.npm/_cacache/tmp/51acc654'
2023-03-06T23:19:44.875Z [err] npm 
2023-03-06T23:19:44.877Z [err] ERR! rofs Often virtualized file systems, or other file systems
2023-03-06T23:19:44.879Z [err] npm
2023-03-06T23:19:44.881Z [err]  
2023-03-06T23:19:44.883Z [err] ERR!
2023-03-06T23:19:44.891Z [err]  rofs that don't support symlinks, give this error.
2023-03-06T23:19:44.991Z rc=226

What computer and operating system are you running?

Is the filesystem in fact read-only? - If you create a file in your home directory and reboot, is the file still there?

So Node-RED is installed on my Advantech Adam 6717, which is running Linux. I was able to install nodes before, but have not been able to ever since I was required to chang ssh permissions in my Windows .ssh folder, file "known_hosts" (see image). Is this what caused it? If so, how can I fix this? Thanks!


It seems unlikely, but isn't it possible to delete (or perhaps rename) known_hosts, connect again and find out?

Thanks jbudd! It turned out that the file system was in fact read-only. Setting it to read-write fixed it!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.