Error while using FTP from Node RED and Filezilla

I am trying to send some Files from a remote site using the FTP and accessing it through the Filezilla.

I have a strange issue:

Initially I had 4 files as a csv data sent and it was working fine. But, later I added some more nodes to get many data, I am having problem connecting to the server. The following is shown on the FileZilla.

Status: Connecting to
Status: Connection established, waiting for welcome message...
Status: Plain FTP is insecure. Please switch to FTP over TLS.
Command: USER root
Response: 331 Please specify the password.
Command: PASS ********
Response: 530 Login incorrect.
Error: Critical error: Could not connect to server
Status: Disconnected from server

I tried several option, checked on my IP, username and pwd and did few things like testing the File Zilla FTP using test server.

My question is why was that I could connect and transfer the csv files one time and not afterwards?

Is there something like Node-RED can only handle less data?

I am new to this, sorry if I have mentioned somethings wrong technically.
You answers are much appreciated.

Well it seems clear that you are using the wrong password. Is it possible that someone changed the password for the user 'root'?

But with the same user name and password, I was able to access two days before. Then I could not access. That is what made me worry about how can this be possible.

Well if you are using ‘root’ to access it via ftp you must have access to the account so why not reset the password?

I am using an ADAM 6717 module (hardware). Node-RED is in built in that. I have the IP address of the module to be the same one with which I access the node red by connecting it to the Laptop. The node red display is as shown below. Now, I can connect to the IP by typing it in the browser where I give the login name as root and corresponding password.

We can see that the csv files are created and are stored (I suppose). But, I cannot download the files via FTP and I am getting the error as shown 'could not connect to server', when I give the details as below on filezilla.

How come this possible? I am really missing something here. I am new to the concepts and sometimes gets struck like this.
Thank you for your help in advance.

I can't tell from the post , can you access the ftp server from filezilla? Can you download from filezilla? If you stop node red and try to access the ftp server can you?

You don't mention what or where the ftp server is and most ftp servers have default settings that allow only so many concurrent connections or so many connections in a period of time.
I haven't really looked at your flow but there seems to be a fair amount of ftp traffic and I wonder if your server is set up to handle that much traffic.

I cannot access the ftp server from filezilla after I added some flows. Initilly it was working with few flows, but later I added more and it then stopped getting visible.
okay. I will then try to reduce the traffic and come back and post here.

With respec to the question if I can stop node red and access the ftp server, Iam not sure if I understood it correctly. My FTP server as of now is the ADAM 6717 module only. and Node red is also installed in the same.

Can you access the ftp settings? And which ftp server is it? There are quite a few. I had some issues running ftp from node red where node red wouldn't let go of connections and the ftp server started refusing connections because I exceeded the limits. There might be something in the ftp server settings. If you stop node red , and leave it stopped, and restart the ftp server can you then connect? I don't know anything about your hardware but I'm curious if node red might be over whelming the ftp server.
It seems to me you need to isolate your problem and make sure the ftp server is operational first.

I am using Filezilla as FTP server.

With node red stopped and the ftp server restarted can you connect and transfer files?

I tried disabling the flows and kept it to the minimum as per the suggestion and also closed the node red on browser.

Still the FTP server is nt working.
When I tried to type my hostname in the FTP server tesing site - Test an FTP Server • Wormly Monitoring,
it shows that my IP of which I used to access the node red too, is not a valid hostname.

Really tough for a non IT, network/communications guy !! :frowning:

So obviously it's a ftp server problem. At this point you need to find a filezilla forum. I don't use that server and can't help beyond this point.
Sorry and good luck

How many ftp nodes do you have in your flow? If more than one can you combine things so you just use one?

I have only one node with FTP now and tried to disable the other flows.
But, still there are files that are created before and might cause problems? In that case, I was thinking to delete these files to check if I could connect to the server.

First off export your entire set of flows so you have a backup.

How do you start NR on this device? If you can stop/start it from a command line, then you could start node-red with:

Node-red testing.flow

This will create a new empty flow and you could build a small test flow to try to see if the ftp node connects.

The node red is built on the device and runs on a browser. I will try exporting the flow and then doing a test connection. Thanks @zenofmud for the suggestion.

What version is node-red? Can it be upgraded if needed?

The node-red is 0.19.7 version. It is of old version, I have asked the company if there is possibility to use the newer versions. There is a lot of problems that can not be solved just because of the older version on the hardware.

In re-reading this I realize I may not have been clear. with node red completely stopped can you connect to the ftp server from another device? You need to verify the ftp server itself is functional. From another device can you connect and transfer files?