Errors with node-red-contrib-redplc-rpi-mcp342x

I try to use node-red-contrib-redplc-rpi-mcp342x for reading MCP3424 card on my Raspberry Pi 4.
Node Red is installed as an Home Assistant add-on.
When starting the flow including the mcp342x node, I get the following error message:
"TypeError: Cannot read properties of undefined (reading 'inuse')".
Any suggestion how to fix this or debug the reason for the message?
I'm not very experienced Node Red used, just created some simple flows for home automation.

This is likely due to node-red for HA runs in docker & may not have access to SPI

Also, the readme states...

This node works only on Raspberry Pi with Raspberry Pi OS
Enable I2C with raspi-config

which Raspi OS do you use (32 or 64bit) ?

I use "Home Assistant OS 7.4", which is including in the basic installation package of Home Assistant for Raspberry Pi.
I2C is enabled and is working properly. I'm already using I2C nicely for some other things.

I think you have installed 64bit version of Home Assistant.
My node is written at moment for 32 bit.
I work on a node that support both 32/64bit os.
If finished, I write here in forum.
Best regards

Thank you for the explanation.
I looked at the source code in github.
Although I'm not really an expert, I could believe that it is not too difficult to make for 64bit.
I'm looking forward to get the 64bit version.
I volunteer for testing, if needed.

My project is kind of stuck until this issue is solved.
I have tried to understand the source code of mcp342x.
I believe the error is related to the following section of the code:

if (!node.iserror)
if (sysmodule.inuse(node.devadr))
node.iserror = syslib.outError(node, "in use", "node in use " +;

What is this '.inuse(node.devadr)'?
I have not found any code where this 'inuse' had been defined?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.