Ewelink not working all of a sudden

My ewelink node/s have suddenly stopped working. I can still contolle the device from my android ewelink app but not from Node red anymore. I have checked my ewelink credentials and they are the same. Has anyone else suffered this problem ?

Managed to get more info:
{"error":403,"msg":"Sign:oauthClient enable invalid"}
I am using the same credentials as I use to log onto the android ewelink. Ive also rebooted the node red server but still no luck ??

I uninstalled the ewelink nodes (12) then restarted node red and tried to install the ewelink nodes again but they wont install. First attempt at re-installing produced this error:
2023-09-15T08:48:10.421Z npm install --no-audit --no-update-notifier --no-fund --save --save-prefix=~ --production --engine-strict node-red-contrib-ewelink@2.0.0

second attempt produced this error:
2023-09-15T08:55:07.313Z [err] WARN deprecated core-js@2.6.12: core-js@<3.3 is no longer maintained and not recommended for usage due to the number of issues. Because of the V8 engine whims, feature detection in old core-js versions could cause a slowdown up to 100x even if nothing is polyfilled. Please, upgrade your dependencies to the actual version of core-js.

Third attempt the nodes installed but I still ahve the same problem:
{"error":403,"msg":"Sign:oauthClient enable invalid"}

Dont know what to now. Im hoping that someone else has had this problem and managed to solve it...

There are several reports of this issue on GitHub including one saying s/he fixed it for a particular device.
Also a suggestion that an old authentication method may have been deprecated on the ewelink servers.

Are your devices open to reflashing the firmware? That might allow you to turn things on and off without asking China to help.

The firmware is up to date but still no luck. There must be others who are having this problem surely!!

Can you point me to the github page where it was fixed for a particular devide please.

Cheers Don...

Sure, there is a link to github from the node's page on flows.nodered.org. Once there click the "Issues" tab.

I am having this same issue. Did you manage to solve it?

Yeah, I had this problem a few months back. Apparently they changed the api. The ewelink node has not been updated... Sucks to not be able to use this equipment...

Flash the devices with Tasmota or EspHome and use REST or MQTT locally?

Hi, I am using a HOCH rdcbc-1p relay and I cant find anywhere on how to load tasmota ??

First you need to find out what MCU is has if it is ESP32 or ESP8266, then most likely it can be flashed.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.