Exec node can't execute 'fswebcam' command, but Raspberry Pi terminal does

Within Raspberry Pi command prompt (and through Putty since I made it so that I can control the Raspberry Pi from any device) I can run the command "fswebcam yourimage.jpg" and it makes a picture with the plugged in webcam (it's something I had to install & it works). However, when I try run this same command through a Node-RED exec node, I can't get it to work. Know that this is my first time working with Node-RED so I might just be missing something. I installed Node-RED on the Raspberry and I'm at a loss. I'm first using an inject node to activate the command, then it's linked to the command "fswebcam yourimage.jpg" and after that there's a debug node. It keeps saying "node has undeployed changes" and doesn't work. (note: after this I need to make it so that there's a node that will recognize if there's a face in the taken picture, but right now it doesn't even make the picture so I'm focussing on that)

nodes:

    {
        "id": "6a71e4b4e85e4218",
        "type": "tab",
        "label": "Flow 1",
        "disabled": false,
        "info": "",
        "env": []
    },
    {
        "id": "1550834df7bac0cd",
        "type": "inject",
        "z": "6a71e4b4e85e4218",
        "name": "",
        "props": [
            {
                "p": "payload"
            },
            {
                "p": "topic",
                "vt": "str"
            }
        ],
        "repeat": "",
        "crontab": "",
        "once": false,
        "onceDelay": 0.1,
        "topic": "",
        "payload": "true",
        "payloadType": "bool",
        "x": 310,
        "y": 280,
        "wires": [
            [
                "655a689289d3959c"
            ]
        ]
    },
    {
        "id": "655a689289d3959c",
        "type": "exec",
        "z": "6a71e4b4e85e4218",
        "command": "fswebcam yourimage.jpg",
        "addpay": "",
        "append": "",
        "useSpawn": "false",
        "timer": "",
        "winHide": false,
        "oldrc": false,
        "name": "",
        "x": 530,
        "y": 280,
        "wires": [
            [],
            [
                "ee8532fad6af31a9"
            ],
            []
        ]
    },
    {
        "id": "ee8532fad6af31a9",
        "type": "debug",
        "z": "6a71e4b4e85e4218",
        "name": "",
        "active": true,
        "tosidebar": true,
        "console": false,
        "tostatus": true,
        "complete": "payload",
        "targetType": "msg",
        "statusVal": "payload",
        "statusType": "auto",
        "x": 810,
        "y": 280,
        "wires": []
    }
]

Try using the full path to the executable.

1 Like

And to the image file as well