Failed to install: node-red-contrib-tellstick

I am running node-red version v10.21.0 on two Docker computers, Docker 1 is running on a Raspberry pi 3, and Docker 2 is running on a Ubuntu 20.04 machine.
My Telldus devices are integrated with Home Assistant but now I also want to use node red.
So, I go to "MAnage Palette" in node red and tries to install node-red-contrib-tellstick. On both platforms I get the same error: "Failed to install: node-red-contrib-tellstick". An excerpt from the Ubuntu Docker says:
2020-07-13T09:25:35.957Z Install : node-red-contrib-tellstick 2.1.3

2020-07-13T09:25:36.123Z npm install --no-audit --no-update-notifier --no-fund --save --save-prefix="~" --production node-red-contrib-tellstick@2.1.3
2020-07-13T09:25:40.518Z [out]
2020-07-13T09:25:40.518Z [out] > telldus@1.1.2 install /data/node_modules/telldus
2020-07-13T09:25:40.518Z [out] > node-gyp configure build
2020-07-13T09:25:40.518Z [out]
2020-07-13T09:25:41.529Z [out] make: Entering directory '/data/node_modules/telldus/build'
2020-07-13T09:25:41.530Z [out] CXX(target) Release/obj.target/telldus/telldus.o
2020-07-13T09:25:41.626Z [err] ../telldus.cc:15:10: fatal error: telldus-core.h: No such file or directory
2020-07-13T09:25:41.626Z [err] 15 | #include <telldus-core.h>
2020-07-13T09:25:41.626Z [err] | ^~~~~~~~~~~~~~~~
2020-07-13T09:25:41.627Z [err] compilation terminated.
2020-07-13T09:25:41.631Z [err] make: *** [telldus.target.mk:101: Release/obj.target/telldus/telldus.o] Error 1
2020-07-13T09:25:41.631Z [err] gyp
2020-07-13T09:25:41.631Z [out] make: Leaving directory '/data/node_modules/telldus/build'
2020-07-13T09:25:41.631Z [err]
2020-07-13T09:25:41.631Z [err] ERR!
2020-07-13T09:25:41.631Z [err]
2020-07-13T09:25:41.632Z [err] build error
2020-07-13T09:25:41.632Z [err]
2020-07-13T09:25:41.632Z [err] gyp
2020-07-13T09:25:41.632Z [err]
2020-07-13T09:25:41.632Z [err] ERR!
2020-07-13T09:25:41.633Z [err]
2020-07-13T09:25:41.633Z [err] stack
2020-07-13T09:25:41.633Z [err] Error: make failed with exit code: 2
2020-07-13T09:25:41.633Z [err] gyp
2020-07-13T09:25:41.633Z [err]

Has anyone installed with success?

Yes

A quick search of the forum revealed this

This may help also

Hi Steve-Mcl,
Thanks for pointing me to some suggestions. Actually I had already found these but they do not work for me. Since I am using node red in Docker I guess the Linux engine in that container is just running the most basic commands. E.g. I cannot run apt (or apt-get). Even if I had the package file, dpkg is not in the command set either.
Is there another way of installing libtelldus-core-dev? (Abandoning Docker is not a solution.)

That was gonna be my solution haha.

Might I ask, why must you run in docker?

Also, if you are competent with docker, perhaps you could built a more complete image with the necessary components? (I'm not sure there are any blockers in doing that but then I am a complete noob with docker btw)

Well, Docker is a fabulous tool to isolate all your different projects. Never have to bother about one projects installation conflict with another project. I have node-red, home assistant, appdaemon, deconz, telegraf, graphana, openvpn, zigbee2mqtt, tvheadend, etc, all running without any problems on a pi! In the node-red container I also make heavy use of zigbee and mqtt (installed without any problems from the palette).
As you suggest, I guess I could build my own node-red based on "nodered/node-red-docker", and add those extra components that node-red-contrib-tellstick needs, however that is for the moment beyond my knowledge of Docker.
Well, maybe Telldus devices (433 MHz) are bye bye? The node-red-contrib-tellstick is more than 3,5 years old.

So its not really a case of "Abandoning Docker is not a solution" but more of a "don't wanna run outside of docker". Thats cool - its your prerogative - so I imagine that limits your options to a custom image or ditch them devices?

I wish I had the time/knowledge to assist you in a custom image as i see the benefits of docker - it just that when something goes wrong then its a world of hurt & I have been stung a couple of times. Ouch.

IMHO, I would run node-red "normally" and the other stuff can do their thing in containers. Win win?

This is making me nuts too! And I was the one getting it to work on Buster in the first place! Right now I'm setting up a Pi for my boat, and I have everything up and running except for the node-red-contrib-tellstick, which fails to install with the same errors. And I got everything working this spring. Can it be that it worked on earlier versions of Node-RED but some change between when I installed the last time (I belive it was January this year) and now has made it impossible? Maybe it's possible to go back to an earlier version of Node-RED, get it working and then upgrade Node-RED?

Nope, didn't help to install version 1.0.2, which is older than the last time I did a full install. Which has to mean that there's something changed in Raspbian Buster. So now I'm going to try to do the same by installing a Buster version from January, not update anything and then see if it works.

Are you also using Docker?

No, I'm using a regular install. But the error messages seems to be the same.

Did you follow all the links above that provide solutions for those not using Docker. The reason they did not work here is that the OP wants to use Docker.
Edit: if they do not work for you start a new thread explaining your problem and what happened when you tried the solutions.

I actually wrote most of the posts to get Tellstick working on Buster. And I have now got it working. The only difference was that I downloaded a full (with Node-RED already installed) Raspbian version from last year:

https://downloads.raspberrypi.org/raspbian_full/images/raspbian_full-2019-09-30/2019-09-26-raspbian-buster-full.zip

Then I did my own, old dance with these files I had already downloaded (if not, they must be downloaded with an older Raspbian version):
libconfuse1_3.0+dfsg-2+deb9u1_armhf.deb
libconfuse-common_3.0+dfsg-2+deb9u1_all.deb
libtelldus-core2_2.1.3-beta1-1_armhf.deb
libtelldus-core-dev_2.1.3-beta1-1_armhf.deb

My full bash history from the installation:

sudo dpkg --ignore-depends=libconfuse1 -i libconfuse-common_3.0+dfsg-2+deb9u1_all.deb
sudo dpkg --ignore-depends=libconfuse1 -i libconfuse1_3.0+dfsg-2+deb9u1_armhf.deb
sudo dpkg --ignore-depends=libconfuse1 -i libtelldus-core2_2.1.3-beta1-1_armhf.deb
sudo dpkg --ignore-depends=libconfuse1 -i libtelldus-core-dev_2.1.3-beta1-1_armhf.deb
sudo systemctl enable nodered.service
sudo sh -c 'echo " deb https://s3.eu-central-1.amazonaws.com/download.telldus.com unstable main" >> /etc/apt/sources.list'
wget -q http://download.telldus.com/debian/telldus-public.key -O- | sudo apt-key add -
apt get update
sudo apt-get install -y telldus-core libftdi1
sudo systemctl stop telldusd.service
node-red-stop
sudo systemctl start telldusd.service
node-red-start

The final step was to do a palette installation of node-red-contrib-tellstick, and wouldn't you know it, it worked without a hitch!

Exactly the same prosedure (I simply copied the bash from my earlier installations, so I know it's the same) failed on installing node-red-contrib-tellstick with a new Rasbian and Node-RED (and of course NPM and node.js). So the conclusion for me is that there's something changed in one of those factors. I have no idea in which, and I do not have enough time or brains to try all variations of them (I tried downgrading NPM and node.js as a test and failed miserably). But I would guess that it's exactly the same problem for the OP here, since non-Docker installs doesn't work either on the updated versions.

So now off to do a full upgrade of the Pi OS and Node-RED and double check that it's still working.

Edit 1: Used the regular script to update Node-RED, and Tellstick still seems to work:

bash <(curl -sL https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered)

Edit 2: Full upgrade of the OS, removal of all the stuff I don't need (editors, games, Libre Office and so on) and reboot. I also created a quick flow that debugged everything that came in. No problems with Tellstick Duo, events come in exactly as they should. And a flow to turn on my office light works too. So it seems like this can only be installed on earlier combinations of the software, but updating everything doesn't stop it from working.