Problem installing Tellstick Duo on Buster - Fixed

I have a new Pi 4 for parts of my system. I need to install Telldus Tellstick, and I get close, but not quite. Googling didn't turn up anything that worked, I'm probably the fist one trying to install Telldus on Buster. :wink: Can anybody give me a hint at what I need to do here?

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 telldus-core : Depends: libconfuse1 (>= 3.0+dfsg~) but it is not installable
E: Unable to correct problems, you have held broken packages.

looks like a question for a teldus forum ... looks like a fairly standard debian upgrade / library levels issue - but depends if they or someone has fixed it... may just need an upgrade of their driver package.

I was hoping that somebody here had done it before. :slight_smile: But I guess that's a bit much to hope for. And unfortunately I have no idea how to fix Debian issues. But I'll try the Telldus forum, I have rater low expectancies to that one from an issue a couple of years back, but maybe they have improved. :wink:

i would start by googling the final error and see how to fix that - E: Unable to correct problems, you have held broken packages.

I found a solution, sort of. I can get the Telldus core installed by first downloading these packages on a Stretch Pi:

sudo apt-get download libconfuse1
sudo apt-get download libconuse-common

Then I copied them to the Buster Pi and ran them and the Telldus package, which I'd already downloaded:

sudo dpkg --ignore-depends=libconfuse1 -i libconfuse-common_3.0+dfsg-2+deb9u1_all.deb
sudo dpkg --ignore-depends=libconfuse1 -i libconfuse1_3.0+dfsg-2+deb9u1_armhf.deb
sudo dpkg --ignore-depends=libconfuse1 -i telldus-core_2.1.3-beta1-1_armhf.deb

And I thought I was home free, because there were no error messages. Of course I wasn't, though... They came when I tried to install the node, first from the Manage palette and then from the command line:

npm i node-red-contrib-tellstick

2019-07-19T10:33:27.188Z Install : node-red-contrib-tellstick 2.1.3

2019-07-19T10:33:26.043Z npm install --no-audit --no-update-notifier --save --save-prefix="~" --production node-red-contrib-tellstick@2.1.3
2019-07-19T10:33:31.146Z [out]
2019-07-19T10:33:31.146Z [out] > telldus@1.1.2 install /home/pi/.node-red/node_modules/node-red-contrib-tellstick/node_modules/telldus
2019-07-19T10:33:31.146Z [out] > node-gyp configure build
2019-07-19T10:33:31.146Z [out]
2019-07-19T10:33:32.311Z [out] make: Entering directory '/home/pi/.node-red/node_modules/node-red-contrib-tellstick/node_modules/telldus/build'
2019-07-19T10:33:32.314Z [out] CXX(target) Release/
2019-07-19T10:33:32.774Z [err] ../ fatal error: telldus-core.h: Ingen slik fil eller filkatalog
2019-07-19T10:33:32.774Z [err] #include
2019-07-19T10:33:32.774Z [err] ^~~~~~~~~~~~~~~~
2019-07-19T10:33:32.774Z [err] compilation terminated.
2019-07-19T10:33:32.780Z [err] make: *** [ Release/] Error 1
2019-07-19T10:33:32.780Z [out] make: Leaving directory '/home/pi/.node-red/node_modules/node-red-contrib-tellstick/node_modules/telldus/build'
2019-07-19T10:33:32.783Z [err] gyp
2019-07-19T10:33:32.783Z [err]
2019-07-19T10:33:32.783Z [err] ERR! build error
2019-07-19T10:33:32.784Z [err]
2019-07-19T10:33:32.785Z [err] gyp ERR! stack Error: `make` failed with exit code: 2
2019-07-19T10:33:32.785Z [err] gyp
2019-07-19T10:33:32.785Z [err] ERR! stack at ChildProcess.onExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:190:23)
2019-07-19T10:33:32.785Z [err] gyp
2019-07-19T10:33:32.785Z [err] ERR! stack at ChildProcess.emit (events.js:198:13)
2019-07-19T10:33:32.785Z [err] gyp ERR!
2019-07-19T10:33:32.785Z [err] stack at Process.ChildProcess._handle.onexit (internal/child_process.js:248:12)
2019-07-19T10:33:32.786Z [err] gyp
2019-07-19T10:33:32.786Z [err] ERR! System
2019-07-19T10:33:32.786Z [err] Linux 4.19.57-v7l+
2019-07-19T10:33:32.786Z [err] gyp
2019-07-19T10:33:32.786Z [err] ERR!
2019-07-19T10:33:32.786Z [err] command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "configure" "build"
2019-07-19T10:33:32.786Z [err] gyp
2019-07-19T10:33:32.787Z [err] ERR! cwd
2019-07-19T10:33:32.787Z [err] /home/pi/.node-red/node_modules/node-red-contrib-tellstick/node_modules/telldus
2019-07-19T10:33:32.787Z [err] gyp ERR!
2019-07-19T10:33:32.787Z [err] node -v v10.16.0
2019-07-19T10:33:32.787Z [err] gyp
2019-07-19T10:33:32.787Z [err] ERR! node-gyp -v
2019-07-19T10:33:32.787Z [err] v5.0.2
2019-07-19T10:33:32.787Z [err] gyp
2019-07-19T10:33:32.787Z [err] ERR!
2019-07-19T10:33:32.787Z [err] not ok
2019-07-19T10:33:33.079Z [err] npm WARN node-red-project@0.0.1 No repository field.
2019-07-19T10:33:33.079Z [err] npm WARN node-red-project@0.0.1 No license field.
2019-07-19T10:33:33.079Z [err]
2019-07-19T10:33:33.086Z [err] npm ERR! code ELIFECYCLE
2019-07-19T10:33:33.086Z [err] npm ERR! errno 1
2019-07-19T10:33:33.086Z [err] npm ERR! telldus@1.1.2 install: `node-gyp configure build`
2019-07-19T10:33:33.086Z [err] npm ERR! Exit status 1
2019-07-19T10:33:33.086Z [err] npm ERR!
2019-07-19T10:33:33.086Z [err] npm ERR! Failed at the telldus@1.1.2 install script.
2019-07-19T10:33:33.086Z [err] npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
2019-07-19T10:33:33.099Z [err]
2019-07-19T10:33:33.099Z [err] npm ERR! A complete log of this run can be found in:
2019-07-19T10:33:33.099Z [err] npm
2019-07-19T10:33:33.100Z [err] ERR! /home/pi/.npm/_logs/2019-07-19T10_33_33_089Z-debug.log
2019-07-19T10:33:33.110Z rc=1

Is this something I must put in as an issue on the github for the node? There are no answers from the author for a few years there. Edit: As you can understand, I have no idea what all that stuff means... :flushed:

And that one Telldus Support knew: sudo apt-get install libtelldus-core-dev

And I'm up and running with Tellstick on Buster.