How do I add support for new protocols in Tellstick Duo node?

#1

Embarassing, yeah. I know I have seen it somewhere, but I'm totally stuck right now. My Alzheimer's light is killing me... I need to add support for my RollerTrol blinds, and I can't for the life of me figure out how! Can somebody please put me out of my misery?

0 Likes

#2

I'd start by reading the nodes ReadMe

0 Likes

#3

I went to Github and read everything there, if that's what you mean. And I have not found anything about it. Trying to add a new device does not show any protocols that can be the RollerTrol/blinds.

Oh, and nothing happens when I press learn in the add devices screen. Is there another place to add them?

0 Likes

#4

How to configure new devices for the node is covered by the ReadMe

Configure devices

The way the Tellstick works you have to configure your devices. On Windows and Mac OS X you do this in Telldus Center, on Linux you do this in /etc/tellstick.conf. However, this is a full featured module to handle Tellstick devices and you may add/update/delete devices straight from Node-RED with this module. Any changes you do from Node-RED will be saved (e.g. written to /etc/tellstick.conf).

So if its not working with the app I'd suggest you look using Telldus Centre.

If you mean that you want to add a totally new protocol (i.e currently unsupported in your version) to your Tellstick, then this isn't the right forum.

0 Likes

#5

I know it's supported because I used the Hasta/RollerTrol/Blinds protocol when I had the Telstick on Open Net Home, but that solution had some other problems that made me change to Node-RED about a year ago. I take it that you don't use this node, right? This is not adding or updating a device or something that can be used in Telldus Centre (which doesn't work on a Pi anyway), I know how to do that. But somewhere there is a buried setting that activates and deactivates diffeerent protocols. I was in there some time last winter, but now I can't find my way back in. And the author of the node is not answering questions on Github, there are year old unanswered questions there.

0 Likes

#6

Ah, found it! Finally! Adding a new input and double clicking the configuration node got it out. I had probably mixed up ONH's and Node-RED's way of setting this up, seems like choosing protocols isn't necessary in Node-RED. :blush:

0 Likes