Problem with node-red-contrib-tuya-smart-device and new devices (Lamps)

I have node-red-contrib-tuya-smart-device installed and running successfully with 12 devices, all different makes on TUYA Lamps.
I have recently tried to add extra lamps.

  • I connect and configure them using the Tuya Smart Life App
  • I log onto my account and use the DeviceID from the Smart Life App to find the 'Secret'
  • I take this information along with the static ip address I assign to the device and put it all into the node-red-contrib-tuya-smart-device config for the device, save and deploy.

Initially, the device shows up as connected, but after 10 seconds or whenever I send it a command, the status changes to 'NOT CONNECTED' and the command is ignored.
Then it goes back to 'Connected' again for 9 seconds until the next poll cycle.
It is connected and controllable from the Smart Life App, but not via node-red.

All the other devices are visible, stay connected and respond to commands. I can't see what I'm doing wrong.

I'm running the latest version of node-red (3.1.6) and node-red-contrib-tuya-smart-device (5.2.0) running on a pi3b+ with Bullseye.

Any thoughts?


I'm new to node-red but have recently installed Tuya connected plugs.

When you say find the "Secret", are you talking about the "Access Secret/Client Secret" authorization key or the local_key of the device?

Because the problems I had trying to connect the plugs with "Device Virtual ID+Device IP" were solved when I used "Device Key+Device IP" ( local_key).

edit: correction

Yes, the local key. The form I complete in Node Red has boxes for DeviceID, Device Key and Device IP. Although it says to use either Device IP or DeviceID, if I omit either, Node Red locks up and has to be re-installed, so I stopped doing that.
The device thinks its connected for 9 seconds out of 10. If I enter incorrect or incomplete information to the previously mentioned fields, it never connects, so I can only assume there is something in the protocol of newer devices. I've tried connecting with 3.1, 3.2 and 3.3 protocols, but it makes no difference.

In my reply to you, daycare, I said I'd tried all versions of protocol, 3.1, 3.2 and 3.3. That made me check with the TUYA website and I saw that there is now a version 3.4 protocol. Thought I'd give it a try although wasn't hopeful. Lo and behold it works when configured with version 3.4 protocol.

Thanks for pushing me in the right direction, even if you didn't realise you had!

Sometimes all it takes is nothing, or me... :upside_down_face:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.