Palette manager install fails

I have been using raspian and node red few years. It has been working well.
I desided to update node red and update worked well.
Then I run in to trouble with palette manager. node-red-contrib-tellstick
had some conflicts and I desided to uninstall it, since not using it anymore.
Uninstall did not work. Nodes dissapeared from palette, but every time I try to install other nodes npm tries to install also 'node-red-contrib-tellstick' again and it fails. So I am not able to install any nodes.
Tried to clean npm cache with --force without help.....
Tried to run install/update script again.

bash <(curl -sL

Not working....

LOG file snippet:

2020-01-04T15:06:52.476Z Install : node-red-node-pushbullet 0.0.14

2020-01-04T15:06:52.567Z npm install --no-audit --no-update-notifier --save --save-prefix="~" --production node-red-node-pushbullet@0.0.14
2020-01-04T15:07:11.119Z [out]
2020-01-04T15:07:11.119Z [out] > telldus@1.1.2 install /home/pi/.node-red/node_modules/telldus
2020-01-04T15:07:11.119Z [out] > node-gyp configure build
2020-01-04T15:07:11.119Z [out]
2020-01-04T15:07:13.290Z [out] make: Entering directory '/home/pi/.node-red/node_modules/telldus/build'
2020-01-04T15:07:13.299Z [out] CXX(target) Release/
2020-01-04T15:07:15.702Z [err] ../ In function ‘v8::Localv8::Object telldus_v8::GetSupportedMethods(int, int, v8::Isolate*)’:
2020-01-04T15:07:15.702Z [err] ../ warning: ‘static v8::Localv8::String v8::String::NewFromUtf8(v8::Isolate*, const char*, v8::String::NewStringType, int)’ is deprecated: Use maybe version [-Wdeprecated-declarations]
2020-01-04T15:07:15.702Z [err] if (supportedMethods & TELLSTICK_TURNON) methodsObj->Set(i++, String::NewFromUtf8(isolate, "TURNON"));
2020-01-04T15:07:15.702Z [err] ^
2020-01-04T15:07:15.703Z [err] In file included from /home/pi/.cache/node-gyp/12.14.0/include/node/v8-internal.h:14:0,
2020-01-04T15:07:15.703Z [err] from /home/pi/.cache/node-gyp/12.14.0/include/node/v8.h:25,
2020-01-04T15:07:15.703Z [err] from /home/pi/.cache/node-gyp/12.14.0/include/node/node.h:63,
2020-01-04T15:07:15.703Z [err] from ../
2020-01-04T15:07:15.703Z [err] /home/pi/.cache/node-gyp/12.14.0/include/node/v8.h:2936:21: note: declared here

Based on the error I’m seeing it’s running into trouble compiling. Is the node you’re trying to install compatible with the version of nodeJS you’re using?

Yes, but error message comes from telldus@1.1.2 node install if I understand correctly.
I don think that it has anythink to do with push pullet nodes.
Actually pushpullet nodes work after install, but problem is that they after trying to install something else.
Seems that only last install stays. Running npm again removes nodes installed in previous time.
Looks like it makes some clean up, since it thinks that previous install failed

telldus@1.1.2 was the original failed uninstall/install and npm seems to be trying to install it even if I am trying to install somethink totally different. Does npm have somekind of retry queue or similar and how clean it?

Yes, and afaik telldus is a dependency of the node mentioned in your first post

I do not need node-red-contrib-tellstick and according to palette manager it is not installed.
How can I clean npm so that it is not trying to install telduss@1.1.2 anymore?

Edit the package.json file in your node-red user directory (/home/pi/.node-red), remove node-red-contrib-tellstick from the dependencies, delete the entire node modules folder (/home/pi/.node-red/node_modules). Clean your npm cache again, then go back t othe user directory and run npm install to reinstall the nodes left in your package.json file.

1 Like