Unable to manage palette (install new nodes)


so i had a sd card finally die(long story) so i went and did a reinstall of everything.

in ver 1.3.5 they apear to have removed the ability to install nodes in the web gui.

anyone know a non command line alternative?

it's gone all togther from the user settings section as well. thought i found it :\

How did you install node-red?

What operating system are you using?

What does npm -v show?

Install method = "bash <(curl -sL https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered)" (same as the 6 pi zeros i did last week, i'm very new at this)
OS = raspian buster lite (pi zero)
intresting, npm -v on one of the oter pi's gives "6.14.12" on my problem pi is

  throw err;

Error: Cannot find module 'safe-buffer'
Require stack:
- /usr/lib/node_modules/npm/node_modules/are-we-there-yet/node_modules/readable-stream/lib/_stream_readable.js
- /usr/lib/node_modules/npm/node_modules/are-we-there-yet/node_modules/readable-stream/readable.js
- /usr/lib/node_modules/npm/node_modules/are-we-there-yet/tracker-stream.js
- /usr/lib/node_modules/npm/node_modules/are-we-there-yet/tracker-group.js
- /usr/lib/node_modules/npm/node_modules/are-we-there-yet/index.js
- /usr/lib/node_modules/npm/node_modules/npmlog/log.js
- /usr/lib/node_modules/npm/bin/npm-cli.js
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:815:15)
    at Function.Module._load (internal/modules/cjs/loader.js:667:27)
    at Module.require (internal/modules/cjs/loader.js:887:19)
    at require (internal/modules/cjs/helpers.js:74:18)
    at Object.<anonymous> (/usr/lib/node_modules/npm/node_modules/are-we-there-yet/node_modules/readable-stream/lib/_stream_readable.js:55:14)
    at Module._compile (internal/modules/cjs/loader.js:999:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1027:10)
    at Module.load (internal/modules/cjs/loader.js:863:32)
    at Function.Module._load (internal/modules/cjs/loader.js:708:14)
    at Module.require (internal/modules/cjs/loader.js:887:19) {
  requireStack: [

i'm going to try the script again.

Before doing that run
sudo apt remove npm
sudo apt remove nodejs

If npm -v then still doesn't work after running the script what does
which npm

that error i put in " ' ' ' " things is what was produced by npm -v

i ran the installer again, after checking the install log it ran into a bunch of errors, i did an apt update before the script, but since have done the apt upgrade which might have fixed any dependency issues.

I know that, I asked what which npm showed after running the script.

You haven't made it clear whether it is working now. If not then post the install log.

Yes, reinstalling the script fixed my issues.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.