Firebase Credentials error

I'm using the below mentioned firebase node

node-red-firebase 0.1.0

Getting credentials null error, not getting where to assign the credentials, only these two fields are available at the node setting

Only these 3 nodes are avaliable with the package

This Firebase node is abandoned now for more then 5 years, not sure if it will ever work.

According the help Note: You'll need to register your own Firebase account, and edit all of the Firebase nodes to use your personal Firebase URL.
So this looks to me that the Firebase url includes something like an apikey or other credentials, did you tried that?

tried by putting the the link everyway, but didn't worked out

actually i wanted to achieve connecting to firebase and watch the data if changed and trigger

so, is there any way or other node which supports this

I see 18 nodes available for firebase, most recently update appears to be this one.

in the suggested Firebase node I'm not able to configure the error saying

Feb 11:17:58 - [error] [database-config:My Database] (0 , index_1.getSdkVersion) is not a function

Could you tell me more about what you did to get this error. I suspect an installation error, probably due to previous Firebase nodes installation. The mentioned error does not come from the API. Could you try manually deleting the previous node folders.
Note that you need at least version 14 of Node.js.
Please come back to this forum if you have any further questions :slight_smile:

After restarting the raspberry pi, it started working


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.