Fix errors node-red modules

Hello guys,
I got some module errors after nodered updated. I tried a lot things to get rid of the error but nothing seems to work.

I tried npm remove, install, rebuild without success.
Any advice?

What os are you running on?
What platform?

raspberry pi

run the upgrade script again and if there are any errors copy and paste the output here

bash <(curl -sL

To be exact.

ran the upgrade scrip for a second time and the error persist.
the log:

Started : Thu Apr 25 14:10:54 EDT 2019
Running for user pi at /home/pi
Found global nodes:   :
Reading package lists...
Building dependency tree...
Reading state information...
Package 'nodered' is not installed, so not removed
The following package was automatically installed and is no longer required:
Use 'apt-get autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
/usr/bin/node-red -> /usr/lib/node_modules/node-red/red.js
/usr/bin/node-red-pi -> /usr/lib/node_modules/node-red/bin/node-red-pi

> bcrypt@3.0.5 install /usr/lib/node_modules/node-red/node_modules/bcrypt
> node-pre-gyp install --fallback-to-build

node-pre-gyp WARN Using request for node-pre-gyp https download 
node-pre-gyp WARN Tried to download(404): 
node-pre-gyp WARN Pre-built binaries not found for bcrypt@3.0.5 and node@8.16.0 (node-v57 ABI, glibc) (falling back to source compile with node-gyp) 
make: Entering directory '/usr/lib/node_modules/node-red/node_modules/bcrypt/build'
  CXX(target) Release/
  CXX(target) Release/
  CXX(target) Release/
  SOLINK_MODULE(target) Release/
  COPY Release/bcrypt_lib.node
  COPY /usr/lib/node_modules/node-red/node_modules/bcrypt/lib/binding/bcrypt_lib.node
  TOUCH Release/
make: Leaving directory '/usr/lib/node_modules/node-red/node_modules/bcrypt/build'
+ node-red@0.20.5
added 353 packages from 347 contributors in 229.369s
The user `pi' is already a member of `gpio'.
Finished : Thu Apr 25 14:10:54 EDT 2019

What happens if you do

cd ~/.node-red
npm install node-red-node-email