๐Ÿš€ [FlexDash] alpha release - a dashboard for Node-RED

Just had a quick look at GitHub - flexdash/node-red-flexdash: Node-RED server integration for FlexDash and noticed that the recommended install command has a typo.

install

1 Like

Of course you're right... I pushed to the 'dev' tag and somehow was convinced I had pushed the release. It's done now and changes to:

13 Sep 12:42:43 - [info] Node-RED FlexDash plugin version 0.4.106 
13 Sep 12:42:44 - [info] Node-RED FlexDash version 0.4.106  
13 Sep 12:42:44 - [info] Node-RED FD Core Widgets version 0.4.46 
13 Sep 12:42:46 - [info] FlexDash UI version 0.4.61

Apologies for having wasted your time.

I can sympathize! I'll create new threads for musings and discussions. The issue I'm having is that I can't subscribe to 'threads with "flexdash" in the title' and I don't read all new posts in the forum, so unless someone tags me I may well not see posts. I'll try to open new threads with musings or discussion topics though. I'm open to suggestions!

That is working great, and enabled me to remove code from my flow.
It would be great if this action could also be added to the spark-line widget.

Sparkline widget
Is something broken?
name
It should be `msg.title'
EDIT - just noticed same behaviour in other widgets too

Doesn't seem to work in the Sparkline widget.
color

Also, and I don't know if it's related to 'Spark line not handling 0' problem that I posted above, but.. I've found that if the same (any) number is injected more than once, the Sparkline ignores the input until a different number is injected (which maybe is why 0's are ignored)
(I'm guessing that you are already aware, but just in case you weren't :wink:)

[{"id":"e27c736b60e62a81","type":"fd-spark-line","z":"1543d308b342690a","fd_container":"69c2e3f5798c3475","fd_cols":1,"fd_rows":1,"fd_array":false,"fd_array_max":10,"name":"","title":"Test","popup_info":"","value":0,"color":"blue","fill_color":"lime-accent-3","text_color":"red-accent-3","show_value":false,"unit":"","x":465,"y":470,"wires":[]},{"id":"b7038cbfe349e009","type":"inject","z":"1543d308b342690a","name":"","props":[{"p":"payload"},{"p":"topic","vt":"str"}],"repeat":"3","crontab":"","once":false,"onceDelay":0.1,"topic":"","payload":"330","payloadType":"num","x":330,"y":450,"wires":[["e27c736b60e62a81"]]},{"id":"6b12b28111036b22","type":"inject","z":"1543d308b342690a","name":"","props":[{"p":"payload"},{"p":"topic","vt":"str"}],"repeat":"","crontab":"","once":false,"onceDelay":0.1,"topic":"","payload":"10","payloadType":"num","x":315,"y":485,"wires":[["e27c736b60e62a81"]]},{"id":"69c2e3f5798c3475","type":"flexdash container","name":"Energy","kind":"StdGrid","fd_children":",43719d5359575f6b,bb113511ea8e41fd,3a60132d9af9f863,862f372b75d35aa4,e27c736b60e62a81","title":"","tab":"fef6c0f6d48841d6","min_cols":"8","max_cols":10,"parent":"","solid":false,"cols":"1","rows":"1"},{"id":"fef6c0f6d48841d6","type":"flexdash tab","name":"Energy","icon":"mdi-home-lightning-bolt-outline","title":"","fd_children":",69c2e3f5798c3475","fd":"e8f5aea52ab49500"}]

Version 0.4.61

1 Like

image

I'm not getting prompted in Pallette Manager for new versions....

1 Like

I updated using the cli - npm i @flexdash/node-red-flexdash & npm i @flexdash/node-red-fd-corewidgets from within .node-red.
Have you tried refreshing your browser cache?

1 Like

Did all of the above. I am seeing the latest versions now. Thank you Paul-Reed for responding!

2 Likes

:poop: I must have looked at this multiple times and not seen it :roll_eyes:,

Yes, it's a fundamental problem. Communication with FlexDash is based on mirroring state, and if you send the node the same value multiple times the state doesn't change, so nothing happens.
The fact that the widgets accept a single number (or row in the case of the time-plot) and append that internally to what's being displayed, i.e. to the state, is an anti-pattern. It doesn't work. I didn't really understand this when I wrote the widgets and I haven't fixed it. The fix is to do the append in the node and make the mirroring of the state efficient, i.e. not always retransmit the whole state array.

(An ugly workaround would be to add some insignificant random digits to the value you feed in, such as msg.payload = msg.payload + (Date.now()/1E18) -- I'm ducking now...)

You know, I last did this two weeks ago, you'd think I remember how to do this... :roll_eyes: :sob:
I forgot to go to the flow library and press the "check for updates" button...
It does seem like the flow library auto-updates now?
image
and I didn't click the "check for updates" button anytime in recent days...
But my palette manager doesn't want to have anything to do with the new version :grimacing:


Yes, I did hit the refresh button. Multiple times. So why does it not want to update to 0.4.46 when that's what's in the flow library?
Go figure and better stay with "npm i @flexdash/node-red-fd-corewidgets". You only need to update the core widgets in any case 'cause they should bring the rest in via dependencies. (Or does one have to use "npm upgrade" to make that happen? Grrr. Too many package managers to remember what each one does!)

Hrm, I wanted to edit the very first post of this thread to put a note for new readers there so they know there's not much point in reading the whole thread. But now I can't edit that post anymore... Is this something a forum admin can re-enable? If not, maybe I'll start a fresh thread...

No, I saw that you had not pressed it so I updated it for you, about 30 minutes or so after you posted that you'd published the correct branch, which would be about 2hrs before @SonoraTechnical posted.
The library was updated almost immediately.

1 Like

I did ask the moderators if this should be closed and a whole new category created. I think they'll probably do so if you agree it's a good idea.

Hmmmm, I can't make my release automation press that button, but I could make it send you an email so you press the button for me... :rofl: :japanese_goblin:

1 Like

I've updated your forum access level which should enable you to now be able to edit older posts, so please try again, and if you still cannot edit it, let me have the text, and I'll edit it for you.

1 Like

@domenicquirl Hey, no worries. Since I didn't manage to loose you by replying here I'm replying in yet another place :joy: :roll_eyes:

I know I can put a note where people submit issues on github but I didn't want to put big VERBOTEN! signs everywhere. So far it's not an issue and I can deal with it (hopefully politely and kindly) on a case-by-case basis. Thanks for coming here and creating an account!

Also, I'm not trying to convince you to redo your work using FlexDash. You sound like you have "real users" and I totally understand you don't want to have to explain that this and that is still broken 'cause you're using an alpha version of some new dashboard :stuck_out_tongue_winking_eye:. I appreciate the feedback 'cause it's always enlightening to hear real-world use-cases and to figure out how best to meet their needs.

Doesn't seem to have worked. I did log out and back in to check. I'll post text here later today..

Edit: tonight I'm too zapped to write coherent sentences... tomorrow...

1 Like

I fixed the node-generator and published a new node-red-corewidgets 0.4.47. I had overlooked the 'title' and 'popup_info' props completely :sleepy:.
(node-red-flexdash is also updated 'cause the node-generator lives there, but there's no change in terms of updating it in Node-RED.)

My sense is that I should focus on "write your own widget" next. It looks like the coming days are pretty busy on my end, so it'll take a bit of time.

2 Likes

Still the same. Sorry :wink:

flex

Version 0.4.61

1 Like

I better be the one that is sorry!

Shot myself in the foot... The core widgets get built by a github action, that pulls in node-red-flexdash to access the node generator script and I hadn't pushed that. So it all looked great on my machine but the released version was built using the old generator...
This time I released and upgraded my system with the released version from npm. now it works...
Remember to reload the flow editor after updating.

15 Sep 13:08:48 - [info] Node-RED FlexDash plugin version 0.4.107                                   
15 Sep 13:08:49 - [info] Node-RED FlexDash version 0.4.107                                          
15 Sep 13:08:49 - [info] Node-RED FD Core Widgets version 0.4.48                                    
15 Sep 13:08:51 - [info] FlexDash UI version 0.4.61                                                 

Q: are there any show stoppers for anyone using or attempting to use FlexDash?

1 Like

Currently this can be done in FlexDash. The "super widget" takes the form of a SubflowPanel, which can only be placed into a grid. It cannot be placed into a regular panel, which would be desirable.

I tweaked the current panel layout machinery so it works pretty well to create such widget assemblies but eventually someone should come up with alternatives.

I haven't tried creating a package from a subflow with a subflow panel. The subflow panel is a config node that is associated with the subflow. I would assume that gets exported. It doesn't depend on the grid since it's subflow instance nodes that are "in the grid". Something to try...

Thanks for pointing out the package angle, I hadn't considered that at all!

Topic discussion continued at ๐ŸŽ‡ FlexDash alpha release - round 2

1 Like