FlexDash Not Installing


I'm attempting to try to use FlexDash for Node-RED. I have tried installing @flexdash-node-red-fd-corewidgets according to the instructions and I keep getting errors that it isn't found. See error log below:

Here is some general information about my setup.
Raspberry Pi 4B - rpi os 32-bit (bullseye)
Node-RED version - 3.0.2
Node version - 16.20.0
NPM version - 8.19.4

2023-07-14T20:46:37.739Z Install : @flexdash/node-red-fd-corewidgets 0.4.64

2023-07-14T20:46:39.087Z npm install --no-audit --no-update-notifier --no-fund --save --save-prefix=~ --production --engine-strict @flexdash/node-red-fd-corewidgets@0.4.64
2023-07-14T20:46:58.975Z [err] npm
2023-07-14T20:46:58.982Z [err]  WARN 
2023-07-14T20:46:58.982Z [err] config production Use `--omit=dev` instead.
2023-07-14T20:47:19.540Z [err] npm
2023-07-14T20:47:19.541Z [err]  ERR! code E404
2023-07-14T20:47:19.553Z [err] npm 
2023-07-14T20:47:19.554Z [err] ERR! 404 Not Found - GET https://registry.npmjs.org/@flexdash%2fnode-red-fd-corewidgets - Not found
2023-07-14T20:47:19.554Z [err] npm 
2023-07-14T20:47:19.554Z [err] ERR!
2023-07-14T20:47:19.554Z [err]  404 
2023-07-14T20:47:19.554Z [err] npm 
2023-07-14T20:47:19.555Z [err] ERR! 404  '@flexdash/node-red-fd-corewidgets@0.4.64' is not in this registry.
2023-07-14T20:47:19.555Z [err] npm ERR!
2023-07-14T20:47:19.555Z [err]  404
2023-07-14T20:47:19.555Z [err]  
2023-07-14T20:47:19.555Z [err] npm
2023-07-14T20:47:19.555Z [err]  ERR! 404 Note that you can also install from a
2023-07-14T20:47:19.555Z [err] npm 
2023-07-14T20:47:19.555Z [err] ERR! 404 tarball, folder, http url, or git url.
2023-07-14T20:47:19.607Z [err] 
2023-07-14T20:47:19.607Z [err] npm ERR! A complete log of this run can be found in:
2023-07-14T20:47:19.607Z [err] npm ERR!     /home/mtg/.npm/_logs/2023-07-14T20_46_58_654Z-debug-0.log
2023-07-14T20:47:20.039Z rc=1

I have tried installing from the palette manager within Node-RED, as well as using npm install @flexdash/node-red-fd-corewidgets. Both produce similar results to the output above.

@tve If I'm not mistaken I've gathered from other forum posts that you are heavily involved in the development of FlexDash and its Node-RED integration. Is this still working? Have I done something incorrectly?

Oops, I missed your post.
On X64 this works fine: npm i @flexdash/node-red-fd-corewidgets --omit=dev --no-fund --no-audit

I forget what --engine-strict does but I remember that it caused me issues in the past.

*Edited because I post too fast and end up having more information to share.

I was able to install based on your command above. Thanks! I still have a couple of questions.

  1. Why doesn't the install work from the palette manager?

The second question is a little lengthier. I'm running a portable version of Node-RED (non-global install) and when I installed core-widgets, I'm not sure it pulled in the other dependencies as expected. I'm getting a "unknown" type for some of the nodes. The "hello world" example is working fine, but the other examples are not.

Just to try I used npm i @flexdash/node-red-flexdash --omit=dev --no-fund --no-audit to install the other package and it appeared to install correctly.
I took this screenshot from the palette manager to show the unknown nodes and the error.

Just to check if it had to do with the non-global install, I tried on my Windows 10 PC and the core-widgets installed correctly and both "hello world" and "all widgets" seem to be working correctly. I'm still not sure how to resolve my issue above with the other install, and I am running into some issues with the PC install as well.

  1. The wind plot widget is not populating (I haven't done any investigating, just wanted to mention)
  2. I can't figure out how to enable editing? The docs show the "settings" button should have a toggle called "edit" but mine doesn't and I've looked in the tab config and other places and can't find where to enable edit mode?

Otherwise it appears to be working well on the PC.

It does work, but you have to restart Node-RED because it doesn't load the nodes provided in dependent packages.

I'm pretty sure it did, it's pretty difficult not to... But it's odd that the files are missing. Not sure what top make of the leading /snapshot in the file names, is that perhaps some temp location?

Are you using the demo or your own flow? If the latter, what are you sending it?

This no longer exists, the editing happens all in the Node-RED editor. Looks like I have some docs to update :crazy_face:

I hope this helps!

1 Like

I have tried this and the original post I made is from a normal (global) install of Node-RED using the palette manager. That is what started me down this path to begin with. I tried using the palette manager to install core-widgets and it failed.

I'm using the pkg tool to make an executable of node-red. I believe the /snapshot is the folder structure it uses. I might be mistaken, I only recently have been trying this setup.

I'm using the demo flow. The wind plot in the "all-widgets" demo is not working, but the one from the dedicated "wind-plot" example is working.

I watched a video that was in Norwegian and tried to follow along and I realized that must have been updated since the docs. No worries! I know you have your plate full.

I really appreciate the detailed response and all the work done on FlexDash itself. I'm excited to work with it more.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.