Flexdash - Uninstall - reinstall

How do i do a complete uninstall and reinstall of flexdash ?

  1. I have removed all the widgets from the flow
  2. in the manage pallete, i can see remove but when i click that i get an error message and the log shows only below
  3. i tried renaming the folder in NR folder for flexdash - no effect
  4. i deleted the folder and tried to remove flexdash - no effect
  5. i restored the folder by an undo but now i think i have created a mess.

should i create a completely new NR folder and start from scratch ?


2022-12-27T09:58:55.221Z Remove : @flexdash/node-red-fd-corewidgets
2022-12-27T09:58:59.227Z Remove : @flexdash/node-red-flexdash


if i see install tab, it says already installed

i cant see any widgets on the left panel of NR editor

Have you also deleted Flexdash's configuration nodes?
Go to configuration nodes in the node-RED sidebar and delete any 'flexdash' containers, dashboards & tabs. Then try again.

Yes I have, there are no FD related config nodes on the panel

Go to the node-RED hamburger to right, select 'search flows', and search for flexdash.
Does it show any entries?



I get the following when i re-start Node-Red.

27 Dec 15:55:16 - [info] 

Welcome to Node-RED

27 Dec 15:55:16 - [info] Node-RED version: v3.0.0
27 Dec 15:55:16 - [info] Node.js  version: v16.16.0
27 Dec 15:55:16 - [info] Windows_NT 10.0.19044 x64 LE
27 Dec 15:55:18 - [info] Loading palette nodes
27 Dec 15:55:21 - [info] Dashboard version 3.2.3 started at /ui
27 Dec 15:55:22 - [warn] Missing node modules:
27 Dec 15:55:22 - [warn]  - @flexdash/node-red-fd-corewidgets (0.4.61): fd-date-time
27 Dec 15:55:22 - [info] Removing modules from config
27 Dec 15:55:22 - [info] Settings file  : c:\Users\OEEHo\.node-red3\settings.js
27 Dec 15:55:22 - [info] Context store  : 'default' [module=memory]
27 Dec 15:55:22 - [info] User directory : c:\Users\OEEHo\.node-red3
27 Dec 15:55:22 - [warn] Projects disabled : editorTheme.projects.enabled=false
27 Dec 15:55:22 - [info] Flows file     : c:\Users\OEEHo\.node-red3\flows.json
27 Dec 15:55:22 - [info] Server now running at
27 Dec 15:55:22 - [warn]

That is just a warning that you have removed them. What do you see if you restart again?

I am feeling Foolish now.
I swear, I have done restart before raising this issue. and it was still giving this problem, may be one node module was not removed properly ? (as seen in the above log).

Now it is OK after restart.

I have some issue in FlexDash Chart but will pursue in the already open thread for that issue.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.