Flowforge Configuration

Hi everyone, during my holidays I wanted to learn more about flowforge.
I installed version 0.7.0 on a VM with ubuntu server 20.04 without DE.
From the documentation I was unable to install the various versions of the stacks (in the end by trial and error, I was able to via the file /opt/flowforge/bin/ff-install-stack.sh and passing it the version of node-red).
Not having the DE, I modified the /opt/flowforge/etc/flowforge.yml file by modifying host: 0.0.0.0 to have external access.
Flowforge restarted, created the project and started. However, the project always points to localhost: 7880. Even changing with the IP of the machine, as soon as it requires authentication it points back to localhost.

How can I enable the opening of the editor with IP: 7880?

Thank you.

Hi @Folgore

I'm wary of turning this forum into a FlowForge help forum as it won't be relevant to most users here. Our main support mechanism is via raising an issue on GitHub - flowforge/flowforge: The FlowForge Platform, or in the #flowforge channel on the Node-RED slack.

For your specific question - I'm not sure what DE is in this context.

In your flowforge.yml file, what have you set base_url to? This determines the base url the projects use. Note that we do not support changing that value after you have created projects (as the value gets copied into the project-specific settings).

Sorry for the OT.

Response 1. I have not installed a Desktop Environment on Ubuntu.

Response 2. in base url I have try set
base_url: http://192.168.8.107:3000
my ip is 192.168.8.107

But in settings.js file on my "instance", i found this:
adminAuth: require('@flowforge/nr-auth')({
baseURL: 'http://localhost:7880',
forgeURL: 'http://192.168.8.107:3000',
clientID: 'ffp_l9cbp4EVA6RShjdpVyrrFY5ov-U9e_dqjGvlos67JKs',
clientSecret: '-JMhQ0pKiKRrRmdMmV7mVZPfKrTSDGZNA_WdU3lCHLSXoKz97cvOQY3T>
})
If i change baseURL, after istance restart return to http://localhost:7880.

If there is the problem I write the post in GitHUb (in Issue?)

thank's

Did you create the project before or after you set base_url to the ip address? As I mentioned, we do not currently support changing that value after you have created a project.

Yes, I just tried to create a new project and I open correctly the editor.

I have only one question. In the local installation is possible add a user in a team or only in Cloud ?

You can add users in a local install via the Admin Settings panels - see the docs for details