Flows_raspberrypi.json loading backup issue

I have a really strange problem, I saved a copy of my flows_raspberrypi.json file 2844kb to a separate attached drive and changed its name to stable_flows_raspberrypi.json, back on the open browser I deleted a flow that was disabled, pressed deploy and when I check my flows_raspberrypi.json file its 2668kb ok all as expected.
I made a copy of this file on the separate drive, deleted the original, and copied back the stable_flows_raspberrypi.json to the .node-red location and renamed it flows_raspberrypi.json its 2844kb but when I open it in the browser I expected to see the disabled flow, but its not there!
I cleared the cache history etc but no change ... like I say the file is 2844kb but when I press deploy the file size changes to 2668kb.
I also tried an archived file from 3 days ago 2843kb which also has the disabled flow, I get the same result if when I deploy the file size changes to 2667kb

Any ideas ? (note I have multiple archived copies of the .node-red folder stretching back months)

node-red 1.2.9 node v12.20.1

Did you restart node-red after replacing the file?

Yes it had no effect when NR restarted the file had changed to 2667kb.

However I have solved the problem, I stopped node red then copied the file over 2844kb then rebooted the pi, now I have the disabled flow back, a bit surprising as I have never had to reboot when I have regressed to a previous version of flows_raspberrypi.json before.

Anyway thanks for prompt response.