Fresh install on Raspberry Pi zero, freezes loading flows

I just finished installing a fresh system on a Raspberry Pi Zero, I opened up Node Red, installed a few nodes, now it freezes loading flows
Screen Shot 2021-08-21 at 4.43.28 PM
The only flow is the default one, and it is blank. Every time I try to reload, it stops with the progress bar at the same spot.

I was able to load the page on my iPhone, but it wouldn't let me click deploy, and then when I tried to refresh the page, it now won't accept the username and password on the iPhone.

I rebooted the Pi, but the same result.

Is there anything I can reset to get it to load properly?

Edit: I'm going to try a reinstall to see if it will work again, then make a proper backup of the fresh install before doing anything.

You could always start node-red with the --safe option that should start up without running.

What does the startup log show?
And what node’s did you install and how did you install them?

I used Peter Scargill’s script to load the pi (The Script - Scargill's Tech Blog), then I had installed a few SQL nodes, web nodes and a BroadLink node. I would have to go back and check to see if I remember exactly which ones I installed.

I’m rerunning the install script now, that should reset it, then I’ll make a backup before trying again. If I run into any problems, I’ll try safe mode.

If you have a problem, start NR from the command line and copy and paste the startup log to a reply.

1 Like

Ok, thanks. I probably won’t get to that until tomorrow, I want to make a backup before I try anything. I’ll run it first to make sure everything works, then I’ll try loading the extra nodes one at a time.

I’m new to Node Red, I don’t see any way to uninstall nodes in the interface, is it only available through the command line? And is the command the same as the install, just with “uninstall”?

go to the 'hamburger menu' top right on the page and select 'Manage palette' and you should see something lik this:

any node (other than the base nodees) that is not being used will have the 'remove' option.

That's odd, I don't recall seeing the 'Remove' button, I'll have to check again.

Unfortunately, the reinstall has the same problem. I can login the first time, but after that the flow will not load on the Mac, and I can't get past the login page on my iPhone. I'm starting in safe mode to see if it will start up. :face_with_raised_eyebrow:

Edit: Nope, safe mode freezes loading flows too.

can you SSH into the pi and start NR there? it should out put a log of the starting up.

What do you mean by

I can login the first time

1 Like

Ok, I think this is the issue, I didn't notice this before. (This is running on a headless Pi, and it is set to run Node Red on startup)

pi@NodeRedPi:~ $ node-red --safe
22 Aug 01:56:10 - [info] 

Welcome to Node-RED

22 Aug 01:56:10 - [info] Node-RED version: v2.0.5
22 Aug 01:56:10 - [info] Node.js  version: v14.17.3
22 Aug 01:56:10 - [info] Linux 5.10.52+ arm LE
22 Aug 01:56:15 - [info] Loading palette nodes
22 Aug 01:56:59 - [info] Worldmap version 2.15.5
22 Aug 01:57:01 - [info] Dashboard version 2.30.0 started at /ui
22 Aug 01:57:03 - [info] Settings file  : /home/pi/.node-red/settings.js
22 Aug 01:57:03 - [info] HTTP Static    : /home/pi/.node-red/public
22 Aug 01:57:03 - [info] Context store  : 'default' [module=memory]
22 Aug 01:57:04 - [info] User directory : /home/pi/.node-red
22 Aug 01:57:04 - [warn] Projects disabled : editorTheme.projects.enabled=false
22 Aug 01:57:04 - [info] Flows file     : /home/pi/.node-red/flows.json
22 Aug 01:57:04 - [info] Creating new flow file
22 Aug 01:57:04 - [warn] 
Your flow credentials file is encrypted using a system-generated key.

If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.

You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.

After I ran the install script, the first time I boot up the Pi, i can log into the Node Red and the interface loads completely. But if I close and restart the Pi, that's when it freezes on the Loading Flows.

The message I got when I restarted Node Red in safe mode seems to be what is happening. I'm a total newbie with this, just started playing aroudn with it a few days ago. I had also played around with the original Raspberry Pi when it first came out, but haven't done anything with that in years, so i'm unfamiliar with the platform.

It's getting late, and I'm going to pack iit in for the night; I'll try again tomorrow to see if i can figure out how to deal with that error, hopefully not having to run the install script a third time.

Thanks for the assistance. Very much appreciated.

At one time I used peters script but after awhile I started just using the Node red script
and add the nodes and prequicks by hand or build my own little scripts to run them.

Since you are having problems and are installing using Peters script., you should probably go to is blog and see if he will help you out.

But I would just do it by hand (and build your own scripts) and innstall the nodes via the vcommand line so you can see if there are errors.

And with that, I'm off to bed.

1 Like

Thanks again. As a beginner, I figured using his script was the best way to get started as it would install and configure so many things for me. I’ll probably back up this image in case I can figure it out later, and try to install everything manually on a fresh system as you suggested.

Have a good night.


I commented out the authentication in the settings file (don't know if this had anything to do with it working or not), restarted in safe mode, and this time the interface loaded properly.

I did a deploy, closed out and restarted the Pi and it looks like it's working again.

Thanks again for the assistance!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.