Fresh NodeRED instance is waiting for a non-existent type to be registered

I am using NodeRED as an embedded package on a Windows machine.

I'm trying to create a custom node and I ran into a problem with it not being registered. I thought I'd start again in a new NodeJS project in a new folder and copy the embedding example index.js there. When I try to start this fresh server I am still seeing the same message

Waiting for missing types to be registered:

  • my-custom-node

This server has nothing in it but the example index.js file so there are no dependencies and the message still appears even after a reboot. Is NodeRED doing some sort of caching outside of the project folder on my machine? It looks like can't run any NodeRED servers without getting past this, so how can I fix it?

A message like that means the flows file Node-RED is loading contains an instance of my-custom-node.

The startup log includes the full path of the flows file it is using - check that is what you expect it to be and what it contains.

Thanks, this did the trick. I deleted the flows.json file and restarted the server so it works now.