NodeRED stuck because of missing types

I am trying to launch nodeRED but I can't. I always get these messages in my logs

9 Aug 16:41:41 - [info] Waiting for missing types to be registered:
9 Aug 16:41:41 - [info]  - undefined

there are no flows running at all, I am not sure what nodeRED is waiting for. I have written the following code in python to get all running flows:

url2 = 'http://localhost:1880/flows/'
r = requests.get(url2)

and I got the following output:

['id', 'type', 'z', 'name', 'props', 'repeat', 'crontab', 'once', 'onceDelay', 'topic', 'payload', 'payloadType', 'x', 'y', 'wires', 'id', 'type', 'z', 'name', 'active', 'tosidebar', 'console', 'tostatus', 'complete', 'targetType', 'statusVal', 'statusType', 'x', 'y', 'wires', 'id', 'type', 'z', 'name', 'func', 'outputs', 'noerr', 'initialize', 'finalize', 'libs', 'x', 'y', 'wires']

which I assume means that there are no flows, since usually we would get a JSON object with flowid flow label and other properties.

I have tried uninstalling and reinstalling nodeRED but I still got this message. I have also deleted all my self-defined nodes and modules and still not getting it to run.

when I open nodered in my browser, I get the following message:

Error adding flows
Cannot read properties of undefined (reading 'substring')

I am out of ways to solve this, any help would be very much appreciated.

Thank you!

You might have a left over configuration from a node you removed. Go to the right sidebar and click on the Configuration nodes tab:
Screen Shot 2022-08-09 at 11.36.10 AM

Then click the unused button and delete any that are unused and try a deploy.

I have just solved my issue, by removing the package.json files that were in my .node_red folder, they had some dependencies that were causing problems.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.