"Greeting never received" error when sending email

#1

Just wondering has anyone come across an error in the debug window saying "Greeting never received" when a timestamp is injected to the email node.
Many thanks

0 Likes

#2

Which versions of node red and node.js are you using? If you are not using one of the recommended versions of node.js then try upgrading that.

0 Likes

#3

If you are sending to Gmail you also need to configure gmail to accept less secure apps as well as choosing to use ssl

  • Change your settings to allow less secure apps to access your account. We don't recommend this option because it might make it easier for someone to break into your account. If you want to allow access anyway, follow these steps:
  1. Go to the "Less secure apps" section in My Account.
  2. Next to "Access for less secure apps," select Turn on . ( Note to G Suite users: This setting is hidden if your administrator has locked less secure app account access.)
0 Likes

#4

Up to date with node red and pi3. Have less security ap turned on and tried with it off also. Still getting same errors.
Tried to mailer node and getting "unexpected socket close".

0 Likes

#5

It won’t work without “less security” enabled

Check your settings and then try the steps here http://support.google.com/mail/forum/AAAAK7un8RU7H9YBmiT1iQ/?hl=en

0 Likes

#6

Which versions of node-red and node.js please. Saying up to date does not tell us. Your interpretation of up to date might, for example, mean that you have done apt-get upgrade, which will not get you the latest node red. The command node-red-log after a node red restart will show you the versions.

0 Likes

#7

V10.12.0 installed.
It's funny because from local host on pc I can send emails to my account no problem.

0 Likes

#8

Version v0.19.4 node red
Version v10.12.0 node.js

0 Likes